X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Unable to login gmail, browser's cookie functionality is turned off. Please turn it on, even after clearing cache, cookies unable, enabling cookies, don't work

Posted

Unable to login gmail. After entering user name and password, says, Your browser's cookie functionality is turned off. Please turn it on. Even after clearing cache and cookies, enabling cookies, starting firefox in safemode, resetting firefox, Says the Same thing. I have tried all troubleshooting information provided by mozilla support and all were unsuccessful in solving the problem. I have the same problem with internet explorer and chrome also.

Modified by chigopalakrishna

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.


You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.
You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6642 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Note that a Reset tries to import cookies, so you may migrate cookie issues to a new profile if you perform a reset.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Can anyone confirm if the above steps work? We are seeing a lot of me too votes without any added context. We need details if we are going to help!

Mukthar 0 solutions 1 answers

the issue didnt get resolved in my computer... its still going on.. i did almost all the above steps..

Regards, Mac

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Which security software (firewall, anti-virus) do you have?

Make sure that your security software isn't blocking cookies if the settings in Firefox are OK.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Still looking for insights here. Anyone tried creating a new profile as cor-el suggested? We need to understand the issue if we are going to fix it!

Selvec 0 solutions 1 answers

Try a different browser, see what happens. I have a similar issue, and it's only resolved when I use the unofficial 64 bit project for Firefox called Waterfox. I suspect this is something beyond just firefox, and rather related to a resource all browsers are using.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8037 answers

We still have a lot of me-to votes. But I note the original post said:

 I have the same problem with internet explorer and chrome also. 

That would suggest the problem is not Firefox specific maybe

  • due to security software
  • a gmail site problem

Also of course a well used site such as gmail is always going to have some users who will report a problem.

Gmail by the way works ok for me.

finitarry 157 solutions 2178 answers

Also, if you are using private browsing mode, you will not get any cookies.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Quote: Also, if you are using private browsing mode, you will not get any cookies.

That is not true, in Private Browsing mode you can use cookies just like in normal mode.
PB mode means that nothing is saved to disk, so you can't create cookies outlast the current session.
In PB mode all cookies are session cookies and expire when Firefox is closed, but you can still block or allow specific cookies based on the default setting.

In PB mode no access is possible to cookies that were created in regular mode and cookies created in PB mode are removed if PB mode is ended or Firefox is closed.


If the settings in Firefox are OK then it is possible that you have security software that is blocking the cookies.

Do you see any cookies being created?

You can inspect and manage the permissions for all domains on the about:permissions page.

zoelace 0 solutions 1 answers

Helpful Reply

FYI - I was having this issue on my mother-in-law's computer. I tried in chrome, and it detected SSL certificate issues, saying that the computer had the 'sirefef' virus. Microsoft Security Essentials can detect and remove the virus, and now gmail works great in both chrome and firefox.

josjos 0 solutions 1 answers

Forget about this website worked for me, thanks.

mecovms 0 solutions 1 answers

I had this problem too. I solved it by uninstalling and reinstalling the antivirus (in my case Avast). I don't know why, but it worked.

rukachan99 0 solutions 1 answers

In my case, the solution seemed to be to turn off and turn on my modem again, probably to get a new IP address or similar, and then, voila, Gmail didn't pick at my cookie settings any more.

shari.anderson 0 solutions 1 answers

Gmail site complained that I needed to enable cookies but all I had to do was clear them. I'm using Firefox v20 on Win7.