X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Windows 8, 64-bit, Flash 11.3, pages not loading properly?

Posted

I've just got a new 64-bit laptop with Windows 8. Websites using Flash keep crashing on Firefox, but work fine on Chrome and IE10.

I tried the suggestions in Hot Topics here 'Flash 11.3 doesn't load video in Firefox' and here 'Flash 11.3 crashes', by downgrading to Flash 10.3, but it didn't help, probably because they're about Windows 7.

Any suggestions gratefully received.

Chosen solution

Yippeeeee! Since the update to Version 19.02, this problem hasn't happened again. I think it's because of FF's own PDF reader, but I may be wrong. Anyway, I don't care what fixed it, I'm just so happy that it's been resolved :-)

Read this answer in context 2

Additional System Details

Application

  • User Agent:

More Information

Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.1
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Add to Amazon Wish List Button
1.10
true
amznUWL2@amazon.com
AniWeather
0.8.36
true
{4176DFF4-4698-11DE-BEEB-45DA55D89593}
Boo.ly Shopping
3.001
true
getbooly@boo.ly
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
gTranslate
0.9
true
{aff87fa2-a58e-4edd-b852-0a20203c1e17}
klout
1.6
true
kwtr-for-firefox@klout.com
Open Bookmarks in New Tab
0.1.2012112401
true
openbookmarkintab@piro.sakura.ne.jp
PDFescape Extension
0.17
true
{2A1D5949-B519-4924-BF62-8522FE0D5274}
Photobucket Uploader
1.3.3
true
pbupload@photobucket.com
Print Edit
8.9
true
printedit@DW-dev
Rain Alarm Extension
1.2.4
true
rain-alarm@mdiener.de
Rapportive
1.4.0
true
rapportive@rapportive.com
RealPlayer Browser Record Plugin
15.0.6
true
{0153E448-190B-4987-BDE1-F256CADA672F}
Speed Dial
0.9.6.10
true
{64161300-e22b-11db-8314-0800200c9a66}
Test Pilot
1.2.2
true
testpilot@labs.mozilla.com
URL Fixer
4.1
true
{0fa2149e-bb2c-4ac2-a8d3-479599819475}
WordPress.com Extension
1.2.4
true
extension@wordpress.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind
true
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.display.use_system_colors
true
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.stopforumspam.com/search|chrome://speeddial/content/speeddial.xul
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
browser.tabs.loadInBackground
false
dom.disable_window_flip
false
extensions.lastAppVersion
17.0
font.name.serif.x-western
Comic Sans MS
font.size.variable.x-western
14
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1353925247
places.history.expiration.transient_current_max_pages
104858
privacy.cpd.offlineApps
true
privacy.cpd.siteSettings
true
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.enable_tls
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics 3000
Vendor ID
0x8086
Device ID
0x0116
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Driver Version
9.17.10.2828
Driver Date
7-31-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.2.9200.16433)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics 3000) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

First, try to update to Flash 11.5, it has some fixes from 11.3. If that doesn't work, try to disable protected mode in Flash. http://forums.adobe.com/message/4468493

Question owner

Your suggestions didn't help, unfortunately. Is there anything else I can try?

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96852 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Well I think I've fixed this myself.

I went into Help, Troubleshoot Information, and then Reset Firefox to its Default State.

So far, so good, but if I have any more of the same problem, I'll post it here.

Question owner

Adobe has just crashed again, after one hour of use. I'm getting really p***ed at this now.

Question owner

Hi Cor-el,

I tried your suggestions and they didn't help either.

Surely I'm not the only person with this problem!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96852 answers

You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin

Question owner

I tried that before I posted my question, and it didn't help. I'm now using Adobe Flash 11.5, and I still have the same problem.

I'm away from home now, until December 11th, so I won't be able to do anything more until December 12th.

Modified by Tricia_TD

Swarnava Sengupta 482 solutions 3135 answers

hey can you try with latest flash player?

ScottDVA 0 solutions 8 answers

I have also had this problem. With Firefox 17 and 18 Beta..

I did all of this and it would work fine for a few hours then crash. I then need to uninstall FF and Flash to get it to work.

There is some compatablity issue somewhere!

Helpful Reply

I now have the latest versions of both Adobe and Firefox, and I still have this problem.

Come on Firefox, get your act together and talk to Adobe about this problem with Windows 8 compatibility.

adrianjames81 0 solutions 1 answers

Any update on this problem? Seriously frustrating. I notice it happens in Chrome too, but not in IE :-/

Helpful Reply

No, no update. It's still happening, and it looks like Firefox couldn't care less.

Question owner

I'm still having the same problem with this.

After looking around the Support Forum, I'm wondering if it could be a 64-bit issue, as FF doesn't run with 64-bit. Or am I clutching at straws?

Chosen Solution

Yippeeeee! Since the update to Version 19.02, this problem hasn't happened again. I think it's because of FF's own PDF reader, but I may be wrong. Anyway, I don't care what fixed it, I'm just so happy that it's been resolved :-)

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96852 answers

Note that Firefox 20.0 is out, so you can update to that version.

Question owner

When the update to version 19 came out, everything worked perfectly, but since I updated to version 20, it's all gone haywire again.

Can you please tell me how to roll back to version 19?

And can you please look at what you did to version 19 that you undid in version 20, and reinstate it?!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96852 answers

Did you already update to Flash 11.7?

Are using protected mode in the Flash Player?

See "How do I troubleshoot Flash Player's protected mode for Firefox?":

Question owner

Flash is up to date on 11.7.

I didn't do anything to put it in protected mode, so I'm presuming it isn't. Should I change it to protected mode? I have Windows 8 64-bit.