X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Yahoo! recommending Firefox 16 for Windows 2000 users

Posted

http://downloads.yahoo.com/firefox/sysreq states

Mozilla Firefox Optimized for Yahoo! System Requirements Windows Operating Systems

Windows 2000, XP, Server 2003, Vista or 7

Dear Yahoo! do NOT rub salt in my wound.

Additional System Details

Sites Affected

http://downloads.yahoo.com/firefox/sysreq states

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Winamp Application Detector
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.1.10329.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.1 r102
  • Provides additional functionality on Facebook. See our web site for details.
  • Delivery Network Acceleration by BitTorrentâ„¢
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1675
  • iTunes Detector Plug-in
  • Npdsplay dll
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.0; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

Have Yahoo! take down misinformation. It is not only wrong but reminds W2K users like myself we are castoffs and the unwanted.

Tim 13 solutions 64 answers

Hi there,

Looks like Yahoo! haven't updated the System Requirements on their site for a while.

Have you contacted them to notify them of their error?

Thanks

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Note that for now you can still use the Firefox 10 ESR version on Windows 2000 until they switch to Firefox 18.
That version still gets security updates.

Question owner

I tweeted Yahoo and they said they would look into it.

I've looked into Firefox 10 ESR and I think I'll stick with Firefox 12.

James
  • Top 25 Contributor
  • Moderator
437 solutions 3157 answers

Helpful Reply

Firefox 10.0.* is more up to date security wise compared to the old Firefox 12.0 as it does not have the security patches that the newer versions have.

Also you may be able to get Firefox 13.0 and newer to work on Win2000 as per http://forums.mozillazine.org/viewtopic.php?f=23&t=2482475

hjm1999 0 solutions 1 answers

here is how i installed firefox 16 on windows 2000

http://www.youtube.com/watch?v=1j7QZYOJUNw

if this is confusing just reply for help

good luck!

Modified by hjm1999