Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cache, cookies and history are not clearing when I close Firefox even though they are set to do so and have been for ages

  • 4 replies
  • 4 have this problem
  • 972 views
  • Last reply by Lainey

more options

I recently had an update (or upgrade?) for FF 16. Today (and I believe the update was done a day or two ago?) my cache, cookies and history are not clearing when I close FF. Also, certain links are not working. Not links for full web pages but for site pop-ups (like the smilie window on a message board). They worked a few days but are not working today. I click the link and nothing happens. I noticed the problem with the cookies not clearing for a few weeks ago but it was only on one site not all sites which is what's happening now.

My apologies if that's a little confusing. Thanks!

Chosen solution

I do use the form fill so private browsing is a bit of a hassle. I just have everything set to clear when I close Firefox.

Regardless, it seems to have fixed itself and is working now so for the time being all is good. I have no idea what happened but it's working.

Thanks for your replies!

Read this answer in context 👍 0

All Replies (4)

more options

I understand what you mean, altough I cannot for sure say what this would happen. It might very well be because you are using a non stable version of Firefox (aka. a beta version, used for testing and for testers to report bugs to the developers).

Do you often use beta versions of Firefox?

more options

Yes, it's a beta and I completely forgot to submit the error through the beta bug system. Thanks for the reminder (and the response). I've just submitted it.

more options

At any rate, have you tried running Firefox in Private Browsing mode? This will ensure that no infromation from your session is saved once you exit Private Browsing mode and/or exit Firefox.

You can set Firefox to always start in Private Browsing mode: https://support.mozilla.org/en-US/kb/private-browsing-browse-web-without-saving-info#w_how-do-i-always-start-firefox-in-private-browsing

more options

Chosen Solution

I do use the form fill so private browsing is a bit of a hassle. I just have everything set to clear when I close Firefox.

Regardless, it seems to have fixed itself and is working now so for the time being all is good. I have no idea what happened but it's working.

Thanks for your replies!