X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keeps returning the error message "Content Encoding Error". There seems to be no fix to this problems. Help or I will stop using Firefox.

Posted

"Content Encoding Error". This error is getting on my nerves. I've installed and reinstalled Firefox many times thinking that the error message would go away. No way! The error message comes up almost all the time. My IE works fine. What gives? If the Firefox team doesn't put its' resources to work and comes up with a working solution, many customers will abandon Firefox. Firefox Tech/Support do your job!

Additional System Details

This happened

Every time Firefox opened

This started when...

Almost every time I access any website.

Application

  • User Agent:

More Information

Explained above. I've also researched the Firefox website for a solution and aslo the internet community. No one seems to have solution.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can check the network.http.* prefs on the about:config page and reset all bold user set network.http prefs to the default value via the right-click context menu -> Reset.

Check at least:

roseharvey 0 solutions 1 answers

I faced this problem when I developed multi-platform apps for smartphone users.

Modified by roseharvey

Helpful Reply

I cannot get passed the error message "Content Encoding Error". This is a serious problem with Firefox and priority should be made to solve this frustrating error. I'm at a point where I have to abandon Firefox. I can't deal with it anymore.

Helpful Reply

Firefox tech support "SHAME ON YOU FOR NOT DOING YOUR JOB".

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Do you have a link to a page that gives the "Content Encoding Error"?

Did you try to clear the cache and cookies and maybe reset prefs?


Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

princesly 0 solutions 5 answers

I share your pain people! I am thinking the issue is somehow related to the current build. For now though if you are a firefox junkie like me, try the following:

1. In the address bar--you know where "www.google.com" normally goes in--type-in about:config

2. Accept the prompt and search for "encoding" and double-click on the "network.http.accept-encoding"

3. In the pop-up window from step 2, remove "gzip, deflate" and replace it with "true" without quotations.

Happy browsing!

(please do not propose to change this pref to an invalid true value as this can cause serious issues, so leave it to the default) - c

Modified by cor-el

princesly 0 solutions 5 answers

Thanks for the warning. I did find that while changing the setting to "true" works at times, it does present an issue later on other websites. I have been going back and forth with the changes with enough frustration and decided to wait for version 17 which I tried a few moments ago still to no avail.

I have also tried resetting my profile as suggested by few here and still no luck. Right now I am using IE or Chrome for normal browsing which is quiet painful as I have missed my Firefox plugins and customization.

It would be much appreciated if someone can help explain what me and others here are missing.

I should add that my system at work with Windows 7 doesn't seem to be experiencing the problem at all. However my Windows 8 platform is still plagued with it.

Regards, Prince

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Firefox should be working properly with the default value of the network.http.accept-encoding pref. I've only see a few times problem reported when it was necessary to disable gzip and only leave deflate enabled because a server did use an unsupported gzip method and needed to be updated.

Which security software (firewall, anti-virus) do you have?

Some firewalls can modify the response headers or inspect the content of packets and corrupt the data while doing this, so Firefox gets raw data and doesn't know that it is compressed and thus shows garbage (gibberish).

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps (this should switch to the Windows firewall).

princesly 0 solutions 5 answers

Did everything to no avail. Even scrubbed Firefox entries in the Windows registry after removing Firefox and subsequent re-installation never worked.

It may be possible that i installed some software that caused the problem. But it is even frustrating that even though the issue only affected Firefox, no one had any specific way to address the issue.

I had scrub my Windows 8 entirely and reinstalled--it is working for now.

Bfoxy2 0 solutions 1 answers

I have this problem as well! It is a "Major Inconvenience", running to Internet Explorer or Chrome to fulfill your needs. Come On, Firefox for your Technical Team, this should be a "NO BRAINER"....

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

You can try to reset Firefox.

If you reset Firefox then a new profile is created and some of your data (bookmarks, passwords, cookies, form data) is automatically imported and your current profile will be moved to the desktop (Old Firefox Data).

You can recover more data from the old profile (be cautious with doing that).

wernerfr 0 solutions 5 answers

Did not works -still content encoding error even on mozilla site

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

So, this still happens in a new profile?

Which security software (firewall, anti-virus) do you have?

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

You can also try to reset (power off/on) the router.

mesvaiya 0 solutions 1 answers

enter about:config onto addressbar, then click i'll be careful,i promise!.then type in serach box network.http.accept-encoding right click then modify the 'string value' from gzip, deflate to deflate

wernerfr 0 solutions 5 answers

I have solved my problem with this error - it was another program: Speedbit Video Accelerator started up automatically with Windows. Once I stopped it "Content encoding error" stopped too.

wernerfr 0 solutions 5 answers

I have solved my problem with this error - it was another program: Speedbit Video Accelerator started up automatically with Windows. Once I stopped it "Content encoding error" stopped too.