Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My firefox is constantly showing page source(HTML code lines) insted of loading page, the only thing I tried was making my browser work faster, could this be connected to my problem?

  • 39 replies
  • 19 have this problem
  • 5781 views
  • Last reply by Vivek

more options

I provided all the details in the question, the problem is simple and random, few sites open as a plain text, instead of loading the full content the way it should be. (followed these steps http://www.forevergeek.com/2004/12/make_firefox_faster/ and http://www.wikihow.com/Make-Firefox-Load-Pages-Faster)

All Replies (19)

more options

http://ufaq.org doesn't wrok, all I see is html codes.. ="top" width="1" style="background-image: url(themes/fisubice/images/7px.gif)"> (and so on)

more options

http://ufaq.org doesn't work, all I see is html codes(plain text)

more options

Try contacting your ISP support, this may be a DNS issue on their end. I have some other minds working on this as well, we'll see what they come up with.

more options

Obviously you are seeing this site properly, so we have to figure out why other sites don't render or why this one does. Try your banking site which is a secure site prepended by "https".

more options

Have another look at the image posted,

What is the image supposed to represent other than a frog in an ice cube? 

When I open http://imageshack.us/photo/my-images/171/adfafaf.png/ I get a frog and a screenshot of firefox under it. The screenshot (ice-cube) is not high quality but apparently is NOT of firefox homepage.

So the primary problem may not be with how the page renders but what it redirects to.

The URL shown in the image looks something like http://staff.bumblr.com (NO it must be a T) {and I note the lowercase NOWIKI markup does not seem to function)

In fact the detail seems to match the sourcecode of http://staff.tumblr.com

Modified by John99

more options

One opinion from another source I contacted on this is that somehow the output from the ISP is requesting text/text instead of text/html. I would still suggest contacting the ISP support.

more options

Thanks for yur advices, I'll contact my ISP support and see what happens. I think this could be due packet losses(foregin pages don't fully load/or load as plain text).

more options

Thanks, let us know. What is still a bit puzzling is why does this support site render ok for you and not the others.

more options

No changes yet, this problem isn't caused by my firewall/antivirus/modem/router/ISP, this is a browser sided error, but I still can't figure out on why this is happening, pages on random show as plain text, and it seems with all the modification I had to make to make my Firefox worlk properly, it only runs slower.

more options

You mentioned you tried Opera and the same thing happens. Did you also try IE? And there is no answer yet as to why this forum site renders properly and other sites don't. Do you see regular html rendering as well on other sites?

What you need to answer before we continue:

  • Does it happen with IE
  • Does it happen on some but not all pages, please provide us with URL's where it happens and where it doesn't happen
  • Have you rebooted your computer
  • What is loading in the system tray at bootup time
  • Have you tried disabling ALL running programs other than what is necessary to maintain OS integrity

Modified by JayGarcia

more options

No IE has no such problems, it only happens on Opera and Firefox(all vesrions). This inproper rendering happens on all http sites(except https). I'm not home right now, but I'll call a friend that's a bit more smarter than me in Web Development.

more options

I found the problem, my Firefox browser sometimes can't load CSS files(it's properties), so instead of trying to load it again it just shows the page as plain text. Is there a way to fix this?

more options

Ah, an important clue. The addon AdBlock is known to cause this problem. If installed and enabled then disable it in Firefox and in Opera.

Also, in Firefox, make sure that View => Page Style that "Basic Page Style" is selected.

Modified by JayGarcia

more options

I just found a partial solution, all you need is CSS updater/CSS reloader/Firebug/Greasemonkey https://addons.mozilla.org/en-US/firefox/addon/css-reloader/?src=search https://addons.mozilla.org/en-US/firefox/addon/cssupdater/?src=search https://addons.mozilla.org/en-US/firefox/addon/firebug/?src=search https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/?src=search This is just a partial solution because some sites(for me tumblr) don't fully load with these add-ons, but a simple refresh makes it render correctly

more options

A "partial solution" is not a solution, only a band-aid and could make things worse. Did you follow my instructions pertaining to AdBlock, etc in my last reply?

more options

I tried all of the above solutions, and they didn't help, my problem was a bit more tricky(I explained it above), and no, I had no AdBlocker, I tried multiple times running firefox without any add-ons/extensions and CSS preferences weren't rendered(on few sites) so it loaded pages as plain text, but as I said above, I'm happy with this band-aid, and hopefully the next Firefox browser will have no such problems with CSS reading/loading.

more options

Ok then, good luck.

more options

I was wrong, pages still open up as plain text, instead of loading the CSS/html properties.

more options

I think you may also be able to find important info in Tools (Alt + T) > Web Developer > Web Console. You have to open it and then start browsing. Clicking on the GET requests would open a new mini window. You can check for the Content-Type:text/html in the Response Headers among others.

Modified by Vivek

  1. 1
  2. 2