Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 8.01 on Debian 6.03 GTK warning problems

  • No replies
  • 3 have this problem
  • 6 views
more options

Folks: just installed Firefox 8.01 on Debian 6.03/xfce. I decompressed the tar.gz file to /usr/local/bin, and typed:

kcredden@equuleus:/usr/local/bin/firefox$ ./firefox

(process:2466): Gtk-WARNING **: This process is currently running setuid or setgid. This is not a supported use of GTK+. You must create a helper program instead. For further details, see:

   http://www.gtk.org/setuid.html

Refusing to initialize GTK+. kcredden@equuleus:/usr/local/bin/firefox$ WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported! This is an application bug! WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported! This is an application bug!

I'm getting a similar error in Thunderbird, but it runs. I'll post info about it in the tbird forums.

Folks: just installed Firefox 8.01 on Debian 6.03/xfce. I decompressed the tar.gz file to /usr/local/bin, and typed: kcredden@equuleus:/usr/local/bin/firefox$ ./firefox (process:2466): Gtk-WARNING **: This process is currently running setuid or setgid. This is not a supported use of GTK+. You must create a helper program instead. For further details, see: http://www.gtk.org/setuid.html Refusing to initialize GTK+. kcredden@equuleus:/usr/local/bin/firefox$ WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported! This is an application bug! WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported! This is an application bug! I'm getting a similar error in Thunderbird, but it runs. I'll post info about it in the tbird forums.