Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since updating to Firefox 7 there is no compatibility with Roboform! What's up? Also your scripts and plug-ins are the worst drag on my PC's peformance...!

more options

Since I updated to your Firefox 7 there is no interoperability with Roboform!!?? What's up? What are you and they planning to do about it?

   Also you have been producing many new version of Firefox recently, but with all of them I continue to have very significant interference with Norton Symantec programs, very serious problems with your scripts which run endessly and which one has to stop or stop Firefox itself completely.
    Your plug-in module also often starts up and then takes interminably long to load.    All in all after Java (whose add-on I have disabled for Firefox) which I need to use for an online job I do, but for which I use Internet Explorer, yours is the slowest program, and the one that causes the most problems and interferences of all the programs I have loaded on my laptop...

Sincerely,

Mark Epstein

All Replies (1)

more options

http://www.roboform.com/support/news
Install Roboform v7.5.0 for Firefox 7 compatibility.