Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm unable to open my Yahoomail with the Firefox web browser. I've already tried reinstalling and Yahoomail works fine in other browsers.

  • 9 replies
  • 140 have this problem
  • 1251 views
  • Last reply by gjlafl

more options

I'm able to access the Yahoo.com website and load the Mail "home page" but once i enter my login information and click "login" an error message appears on the screen "404: Not Found". I can access yahoo mail in other browsers; just not Firefox.

I've already tried the following: deleting cookies; deleting temp. files; reinstalling firefox; upgrading firefox; checking your website for information but no one seems to have given a solution and this apparently has been a problem with firefox for awhile.

All Replies (9)

more options

I sure hate not being able to use Mozilla Firefox because I can not view my AT&T Yahoo e-mails. I get 404 Not Found and nginx/0.6.32. Anyone out there including Firefox chat personnel that can "fix/cure" this problem? All the other browsers have NO PROBLEM. I even had AT&T ConnTech personnel work on the problem. No solution!!! Gene C.

P. S. I think Mozilla Firefox is the best but now NO AT&T Yahoo e-mail.

more options

Troubleshooting extensions and themes

Cannot connect after upgrading Firefox

Firefox cannot load websites but other programs can

Cannot log in to websites

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Tools Menu -> Options -> Privacy -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode -> place Checkmarks on:

1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> click Exceptions... button -> type the addresses of websites on which you want to Allow cookies e.g. mail.yahoo.com , login.live.com ,etc. 4a) Accept Third-party Cookies -> Keep Until : select They Expire

  • REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES
  • Click OK on Options window -> Restart Firefox

Check and tell if its working.

more options

I followed all of the steps TO THE LETTER with so much hope and it didn't work lol This really sucks too cuz i love Firefox; i left IE to start using it. But one of the first things i do everyday is check my email..Firefox isn't letting me.

I'm still getting the same message: "404 Not Found/nginx/0.6.32"...

Any other suggestions?

more options

Is Yahoo! MAil working on your other Web Browsers (IE, Chrome, Safari) ??

more options
more options

Yes, AT&T Yahoo e-mail works on the other browser such as Safari, Opera, Chrome, and Internet Explorer. Even going to Yahoo's web site let's you view their @yahoo e-mail address that I have but not Mozilla Firefox. Anyone got an e-mail and/or telephone number to get this on the major bug list?

more options

I had another session yesterday with AT&T Connect Tech online hardware and software support. Well he worked on the problem for over two hours and even loaded an older version of Mozilla Firefox. Result was the same 404 Not Found nginx/0.6.32 every time I go to AT&T's http://att.my.yahoo.com home web site. I can see about five e-mails (who they are from and the subject line BEFORE going to the mail button to sign on but once giving them your e-mail address and password, SAME results using Mozilla Firefox.

I tried the suggestion given but also get the same results. This is a major bug either at AT&T and/or Firefox.

more options

-> Tap ALT key or press F10 to show the Menu bar

-> go to History Menu and click Show All History -> Library window will open -> Search for the website you want to remove from your history by typing its name in the Search History field in the top-right corner and then press Enter -> Then, in the search results, right-click on the site you want to remove, and click Forget About This Site

-> Close the Library window -> Restart Firefox

Now do this:

  • Go to the website you wish to Allow from setting Cookies in Firefox
  • Right-click empty space within the page and click View Page Info
  • In the Page Info window, select the Permissions panel
  • Underneath Set Cookies, place Checkmark on Use Default
  • Change the setting to Allow
  • Close the Page Info window

See this for you guidance through GUI:

Check and tell if its working.

more options

Found out that AMALAHI and I had same solution, deleted Anti Phishing Domain... Now my mail works fine. Apparently while I downloaded free Chistmas animated screensavers ( for Mom (visiting)) this was included and it was Panda when I clicked on support info. Restarted Mozilla firefox newest version and I can read my old Yahoo mail fine. I access mail from My!Yahoo. I place hand on mail then click first one and I am still in old reliable version. I have new mail in another login elsewhere and do not care for "improved" version.