Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I avoid the plugin check page?

  • 9 replies
  • 15 have this problem
  • 44 views
  • Last reply by cor-el

more options

Every time I open Firefox now, I get a second tab taking me to the plugin checker page. I updated all the vulnerable ones, and I just don't want to see the thing every time I open firefox! Can I disable this annoying feature?

Chosen solution

I uninstalled Viewpoint Media Player (and the AOL IM client "AIM", since apparently that's what forced Viewpoint Media Player on to my system.) Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled. For me, after uninstalling Viewpoint Media Player, the "plugincheck always opening" problem then went away.

I see, however, that you do not have this plugin ("MetaStream") in your plugins list. So it may be that there is some other plugin of yours that is causing this tab to pop up. Go to Tools->Addons->Plugins(tab), and look in the list for any plugins with a red warning icon. If there are any, this is probably the plugin causing the problem.

Read this answer in context 👍 1

All Replies (9)

more options

Firefox can store multiple home pages, it is possible that the plugin check page has been set as a home page. Try resetting the home page to the site that you want as shown here - https://support.mozilla.com/kb/How+to+set+the+home+page

Modified by TonyE

more options

Unfortunately, this didn't solve my problem, although it now comes up only every other time I open Firefox

more options

Modified by mikeclark

more options

Type about:config in the URL bar and hit Enter.
If you see the warning, you can confirm that you want to access that page.

Pref = plugins.update.notifyUser if it shows as True, double-click that pref to toggle it to False

If that pref was already set to False, try disabling the QuickTime Plugin and then restart Firefox, to see if that is the culprit.

Modified by the-edmeister

more options

Chosen Solution

I uninstalled Viewpoint Media Player (and the AOL IM client "AIM", since apparently that's what forced Viewpoint Media Player on to my system.) Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled. For me, after uninstalling Viewpoint Media Player, the "plugincheck always opening" problem then went away.

I see, however, that you do not have this plugin ("MetaStream") in your plugins list. So it may be that there is some other plugin of yours that is causing this tab to pop up. Go to Tools->Addons->Plugins(tab), and look in the list for any plugins with a red warning icon. If there are any, this is probably the plugin causing the problem.

Modified by mikeclark

more options

The reason you don't see it was because as soon as I got your reply, I did exactly as you suggested. And it worked. Thank you so much!

more options

Hi. I don't have Viewpoint Media Player but MetaStream is listed on my plugins list with a red circle/exclamation point. It is disabled. Can it be deleted from the list?

Also, on the Plugin Check, it keeps telling me to update Adobe Acrobat but it is update and the current/updated version is actually listed on the Plugin Details list. Under Status it says 'outdated version' but it's not.

So we now have a new wrinkle. Please let me know if you have a solution. Thanks!

more options

Veiwpoint Media player is not in your firefox plug ins. It is a separate program that might be in your start menu or your program files. It is only with the uninstallation of Veiwpoint Media Player that I was able to get rid of the obnoxious plug in check

more options

That is a bug with blocklisting plugins that has been fixed.
You can correct this issue by forcing the file blocklist.xml to update or wait until Firefox updates the file.
That update will remove the severity="0" flags in the file that cause the problem.

See:


  • Bug 663722 - The blocklist output is including severity="0" where it shouldn't be