Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some website are not recongizing the latest update

  • 4 replies
  • 3 have this problem
  • 19 views
  • Last reply by cor-el

more options

When I go to some website I get the message that I cannot browse their site because I don't have the latest version of Mozilla, I do I have downloaded it 20 times. I have rebooted my computer. Everything. I have many more sites than the one I listed. Facebook gives me trouble by not always keeping everything current.

All Replies (4)

more options

Yes, that's correct, the version of Firefox you have installed is too old.

Please do the following.

  1. Go to Download Firefox 4.0.1 and download the installation file to your desktop.

  2. Then go to Add/Remove Programs, scroll down to "Mozilla Firefox" and remove it, choosing to keep your bookmarks, customizations etc., (don't checkmark the box).

  3. Then reboot and delete the folder called "Mozilla Firefox" at this location: C:\Program Files\Mozilla Firefox

  4. Finally run the installation file (that means double click it) you downloaded to the desktop earlier.

Your bookmarks, customizations etc., are maintained in a different location and will become available to you again once you complete the installation.

more options
more options

Ed, it's not a good idea to keep the version jennifer is using because it's a security risk.

@ jennifer, an SSL Provider (SSL is what banks use to encrypt sites) called Comodo experienced a security breach recently which resulted in a number of fraudulent certificates being issued. These certificates will allow criminals to create a fake banking site which looks exactly like your own and the version of Firefox you have installed at the moment will not warn you that it's fraudulent.

Comodo's blog explains the risk here: http://blogs.comodo.com/category/it-security/data-security/

These certificates were blacklisted in Firefox 3.6.17 and beyond. The version I linked to is the current one.

more options

Looks to me as well as a corrupted user agent, so check out the Knowledge Base article in Ed's post and reset the pref general.useragent.override to the default (empty string) on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
You can use the Filter bar at to top of the about:config page to locate a pref more easily.

Modified by cor-el