X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

hate sidebar, how do I get rid of it and revert to opening bookmarks from toolbar

Posted

Hate the sidebar. How do I get rid of sidebar and open pages in a new tab from the bookmark toolbar. I have ticked "open in new tab" in preferences and installed an add on. Neither work. Am I missing something ? is there a way to open bookmarked pages in new tab simply by clicking on it in the bookmark toolbar. If not whats the point of having it there.

Chosen solution

Middle-click or {Ctrl + Click} on a bookmark should open that bookmark in a new tab.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • iPhoto6
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 20-20 Technologies - 20-20 3D Viewer v4.5.4.0
  • Shockwave Flash 10.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24387 answers

Chosen Solution

Middle-click or {Ctrl + Click} on a bookmark should open that bookmark in a new tab.

Question owner

{Ctrl + Click} works, thanks, but I'm lazy and it's still prefer the single click and I'm there. Can I get rid of the side bar for good without having to x out each time ?

Question owner

Oh dear, it sometimes works and other times not. I get the dropdown with open in new tab option.. it's so cumbersome compared to click and hey presto...

mlambert710 0 solutions 2 answers

I had the same problem. Couldn't stop the sidebar from loading when launching FF4. Finally just used the tried and true method: uninstalled FF4 and then re-installed it from a fresh download of the setup file (backed up my bookmarks first, of course, which is pretty easy in FF!). (When uninstalling, I checked the box for removing all personal preferences. This was key.)

After the re-install, the problem seems to have cleared up. I've re-imported my bookmarks and now I'm good to go. I may have to re-install a few add-ons, but that's ok since many of them weren't compatible with the new FF version anyway.

(PS: I'm using FF on a PC running Windows 7 Enterprise 64-bit.]