X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 4 - Slow Video Streaming/Buffering??

Posted

I just downloaded firefox 4 -BRILLIANT! However one small problem. I have a 10MB/s wifi connection, cleared my internet cache and history more then once, no other tabs or programs running but my online web videos are loading slow, and I watch them a lot since I miss them on TV. From sites like wisevid or karambavideo they used to load so fast, now they are soooooo slow and it's unbearable. Any ideas?

Additional System Details

This happened

Not sure how often

This started when...

I downloaded Firefox 4

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • BitCometAgent v1.19 for Firefox
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Version 1.1.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

SLOW VIDEO STREAMING - HELP!

chikoy 0 solutions 1 answers

same for me.. mozilla 3.6 was much faster video, mp3 streaming

Question owner

Yeah, I agree, I tied downgrading and they kept complaining that it was "out of date" and wouldn't function properly

Deerdryad 0 solutions 1 answers

Dear Firefox 4 users, there is an extension on Firefox 4 called BFlix Toolbar that I removed, and immediately my streaming/buffering was back to normal, meaning that there was no video lagging, and things just generally sped up.

To remove this, go to Tools, which should be up at the top of your screen, and click 'Add-ons.' This should open up a new tab labelled 'Add-ons Manager.' On the left hand side, there should be a list, with 'Get Add-ons,' 'Extensions,' 'Appearance,' and 'Plugins.' Click 'Extensions.' There should be a list, and BFlix Toolbar should be there. Disable and remove it.

I hope this helps! It worked for me, and I sincerely hope it works for you! Have a lovely day/night.

drsleep 0 solutions 1 answers

Definitely same problem here. Worked fine pre-4

kenryu1981 0 solutions 2 answers

I had a problem with streaming under Firefox 4: when on youtube, I had the sound but a black screen instead of the video after disabling, and enabling my plug-ins one by one, I realised that the problem came from Tile Tabs, a plug-in used to tile tabs under the same window. I do believe that if you have any plug-in from that kind (it is the case with Split Browser also !!) you just should remove them for moment , and it makes videos in streaming come back Hope I helped

rafa0105 0 solutions 1 answers

same here on all my 3 of my mac computers.

edoupe 0 solutions 2 answers

thanks but everything is still slow, don't know why it is doing this maybe the best bet is buy another computer and get a different internet provider any suggestions

TobyJugg 0 solutions 4 answers

Things started getting very slow through the Firefox 3 series, then 4 and now version 5. Things like BBC iPlayer or News items. I tried Safe mode but it did the same, even after re-installing Firefox 5. At the end of some news items, the video window gets several small pictures across it, listed as 'Similar items'. The borders of each would turn yellow when you mouseover them but I could not access them and... I couldn't see the pointer. I eventually discovered that you could cure the problem by right-clicking the toolbar at the bottom of the screen. I also discovered that 'halting', 'blank' or 'jumping' videos could be unlocked (or at least helped slightly) by doing the same thing. XP Pro - CPU 2.66Gigs - 2 GB RAM - Nothing running in the background apart from anivirus. Any ideas...?

Modified by TobyJugg

ThrillKiller 0 solutions 1 answers

I had the same problem. I have a Gaming set-up. 8 GB Ram,High end G-Force Video Card,Dual Quad Core processors. Adobe & Flash all updated,etc,etc.

YouTube worked great. Even 720p and 1080i Vids loaded fast and played smooth. No lag. Same with Netflix. Watching Hi-Def Instant Watch Vids never Downgraded to a slower/lower bit stream. It only happened with "Live" streams. Like from the local news station and Live streaming shows of various Concerts.

So,I followed the suggestion about Plug-Ins. I removed all of the ones dealing with Zoom/Magnification. Since I never use them anyways. I didn't have any of the ones listed. And just tried those just to see what happened.

I closed FF. Re-opened it. And VIOLA. My live video streaming was back. Synced sound and all. No lag.

I did this on 6/3/12. It worked for me. and my lag was happening with Comcast 20 Mbps service. Speedtest actually clocked it at 17.62 Mbps. Still, it shouldn't have lagged. But I'm good now. Maybe it'll work for you?

PS: I have the latest FF vers. as of the date of this post. (vers 12.0)