Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

downloaded FF 3.6 setup.exe wont upgrade from FF V 2.0.0.20. running ME on old laptop. Is this upgarde possible?

more options

Running ME on 2000 vintage toshiba laptop

All Replies (3)

more options

Nope, 2.0.0.20 is the last version of Firefox that is compatible with Windows 98/SE/ME.

more options

Thats what i thought. Any suggestions regarding an upgrade to the Windows OS or maybe Linux? Its is an 850 Mhz pentium, with 128M ram laptop and is like part of the family. Many thanks for your help.

more options

Firefox 4.0 is going to need a P4 processor and a lot more RAM, along with W2K-SP4 or WinXP-SP3or4. Firefox 3.0 and 3.5/3.6 would work with W2K or higher, but would be real limited with only 128MB of RAM - IMO, 512MB would be the minimum to go with.

Linux might be the best path to follow. See which Linux distro would best support an older processor like that.
http://distrowatch.com/