X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Mouse hover is not working with Firefox 4 at all

Posted

Since upgrading to the Firefox 4 RC (Mac, 10.6), I cannot hover on anything. My mouse cursor does not change at all. Please note, Firefox 3.6 and earlier worked perfectly fine.

For instance, if there's a drop down CSS menu (not a select box), I cannot hover over it to see it. I have to click before the :hover psuedo-selector is even applied. Also, when hovering over items in the bookmarks bar, the hover effect isn't applied there either.

I've disabled hardware acceleration, used AppZapper to completely remove Firefox, but nothing worked.

Is anyone else having this problem?

Additional System Details

This happened

Every time Firefox opened

This started when...

Upgrading to Firefox 4 from 3.6

Installed Plug-ins

  • iPhoto6
  • Shockwave for Director 11.5.8r612
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 4.0.50826.0
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110303140758
browser.startup.homepage_override.mstone
rv:2.0
extensions.lastAppVersion
4.0
layers.acceleration.disabled
true
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
257698
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
0x22600,0x24300,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows
0/1

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Try "Reset all user preferences to Firefox defaults" on the Troubleshoot Firefox issues using Safe Mode start window.

See also:

Question owner

Hey there, I already tried safe mode. I also tried making a completely new profile. Since that didn't work, I completely removed Firefox with AppZapper.

This is unrelated, but since it's a mouse issue, I tried resetting the mouse by plugging a USB one in then unplugging it.

jamessg 0 solutions 3 answers

I'm having this same problem. It's not just websites that don't have the :hover - the problem is the same in my bookmarks toolbar (nothing is highlighted when hovering over bookmarks)

I am on Mac OS X 10.6.6 and am using Firefox 4.

I can make the hovers work again properly if I hold down my mouse button (eg. if I click and hold on the Firefox 'Home' button and then move the mouse onto the page all of the hovers will work as long as I keep the mouse button held down)

jamessg 0 solutions 3 answers

I feel a bit silly but I just restarted my computer and the hovers are working now.

echozone 0 solutions 6 answers

A restart resolved it for me too, but it was only temporary, I didn't determine what triggered it again, but the issue immediately returned, hovers are non responsive to html (pseudo class on links), css or javascript, and cursor stays as ibeam, rather than pointer.

bruceclark 0 solutions 2 answers

I have this problem as well. Restarting the computer did fix it but only temporarily. This is on 10.6.6 and 10.6.7 (installed after FF4 was).

It effects all types of hover :hover, javascript onhover, and even the web developer toolbar plugin for style information. Holding down the left mouse button will temporarily fix it but obviously highlights the text too.

Here's a quick video: http://screencast.com/t/Q30Tra3PwfIi of the issue on just a standard hover link. Notice when I click down and hold it will work but the highlighting of text also starts happening, as it should.

@bruce on Twitter if you need more details.

echozone 0 solutions 6 answers

Helpful Reply

I tracked it down to a conflict with xScope! Quitting this app (which I always keep launched) makes the issue completely go away in FF, and launching it makes it consistently happen. Entirely reproducible. Reporting to Iconfactory now.

For others that have this, can you find another program that when launched causes this but when quit results in the issue disappearing in FF4, or do you also have xScope (by iconfactory) active while seeing this? I'm running 10.6.6.

I only have FF as a testing browser (front end developer), Safari is my main browser. I also tested with extensions disabled (Firebug + FireQuery) and they are not involved in the conflict.

Question owner

Dude! Yes! That instantly worked for me too :-)

sbarner 0 solutions 1 answers

I am having the same problem on a Windows XP computer. The cursor does not change when I mouse over most links. On pages where CSS has turned off link underlining, there may be no indication that you are over a link at all, other than the URL appearing at the bottom of the page. Interestingly, the cursor turns into a hand when I mouseover the tools in the editor on this page, and the green Post Reply button, but not over any other link on the page.

A problem which may or may not be related is that the browser Back button is nonfunctional and the Back command in the context menu is grayed out.

echozone 0 solutions 6 answers

Can people report if they have hover working with all other apps quit, but have seen hover broken, isolate another program launched with FF4 that triggers this? It might be a certain characteristic of that second app, as xScope does use hover functionality.

I've reported this to iconfactory, but thinking this may be on FireFox's side, since other's are reporting here, and for one thing, xScope is mac only. I found nothing like this over at bugzilla.mozilla.

Modified by echozone

bruceclark 0 solutions 2 answers

YES! This fixes it for me to, although sad because I love xscope. If you have a bug report. If there is a link to upvote the icon factory bug let us know!

echozone 0 solutions 6 answers

It seems it may be Firefox's bug, since it started with a new version of FF, not xScope, and a post above reported similar on Windows, where that couldn't involve xScope. I suspect a similar type of app is open when this is happening, that has to do with global screen hovering. This is why i asked for other evidence of a reproducible conflict with another program.

Here's the bug report I just submitted: https://bugzilla.mozilla.org/show_bug.cgi?id=645306

You can enter a "vote" next to "importance".

Modified by echozone

semila58 0 solutions 1 answers

Same problem after updating to Firefox 3.6.16, on Mac OS 10.5.8. The only other program running was Growl which gets installed by Adobe CS5: http://growl.info/thirdpartyinstallations.php

Uninstalled Growl and CS5 demo, did restart, still have the mouse problem! Just posting this reply was quite an ordeal...

jamessg 0 solutions 3 answers

I've tracked down my problem too... I had a program called uPointer running (it puts a circle around my mouse pointer so I can find it) when I turn it off the hovers in firefox work and when it's on they don't - I think it must be a Firefox issue as I had no problem on the last version while using uPointer

echozone 0 solutions 6 answers

@jamessg, great! This gives weight that it is Firefox's bug, in conflict with utilities that effects hover globally. I've added this to https://bugzilla.mozilla.org/show_bug.cgi?id=645306

Question owner

To add to the weirdness here, Firefox 4 and xScope run perfectly fine together on my MacBook Air.

Younis M.Jad 0 solutions 1 answers

Helpful Reply

guys check your login items and disable all of them and logout then login, there are some interface app that does conflict with FF4, i had it fixed by this and it was app conflict issue.

Replay if it worked

echozone 0 solutions 6 answers

We have already established that it is a conflict with utilities that effect screen hovering globally. You can vote for importance of this bug at the bugzilla bug report at: https://bugzilla.mozilla.org/show_bug.cgi?id=645306