Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Updated to Firefox 4RC and have no functionality on any search engines, cause freezing of browser, any ideas? Running windows 7

  • 8 replies
  • 120 have this problem
  • 37 views
  • Last reply by flutterby

more options

I am running Windows 7 and have/did update to various 4 betas/release candidate. Have tried using various search engines to no avail. I am able to conduct initial search, results are displayed, unable to open links and lose all functionality in browsing causing freezing.

Yahoo, Google, Bing, all are affected.

Chosen solution

Do you have McAfee Site Advisor installed, that extension has been causing problems particularly with Google. If you have it try disabling it to see if Firefox works. You can also try installing the latest version (3.3.1) of the Site Advisor, that one should work.

Mozilla are planning on blocking older versions of McAfee Site Advisor in Firefox 4 due to the problems they cause.

Read this answer in context 👍 9

All Replies (8)

more options

Chosen Solution

Do you have McAfee Site Advisor installed, that extension has been causing problems particularly with Google. If you have it try disabling it to see if Firefox works. You can also try installing the latest version (3.3.1) of the Site Advisor, that one should work.

Mozilla are planning on blocking older versions of McAfee Site Advisor in Firefox 4 due to the problems they cause.

Modified by the-edmeister

more options

Updated and installed McAfee Site Advisor and it is fixed. Thanks for your help, I wouldn't have even thought of that being the issue. Thanks again!

more options

This did not work for me..., so it is still an flaky fix

more options

I also had this problem in Firefox 3 and then in Firefox 4. I would search in Google and suddenly Firefox Froze and the only way I could Browse in Firefox was to shut it down. It just couldn't on like this so I thought it must have something to do with one of the add-ons. I disabled Auto-Pager and then Search Preview but that didn't work. So in desperation I found this question and decided to try disabling "Bullguard" (Ant-virus) Safe Browsing Tool-bar.....and Google works fine......no more freezing. So thanks guys for helping me solve the problem. I love Firefox and especially Firefox 4......Keep up the good work

more options

After having installed Firefox 4 I started to experience regular episodes of freezing. I was receiving the message 'Firefox not responding.' I use BullGuard Antivirus and I understand that there is a compatability problem with the BullGuard Safe Browsing option. Having disabled this, my freezes have ceased. BullGuard are aware of the problem - there is a post on their forum in the section for Bullguard Customers and under the heading ' Safe Browsing Toolbar Problem.'

more options

After upgrading, which was suggested, I am unable to browse with firefox. I tried to go back to the older version after and uninstall of the new and still the same has occurred. Message in a tool bar states it is temporarily off line and will restore shortly but it has been happening for days. I am going to uninstall firefox and will be forced to use a different browser until it is cleared up. Hopefully soon

more options

2 weeks on and this is still happening with Bullguard as everyone switches to Firefox 4, my computer had a total freeze up including the task manager. Finally found that BullGuard Safe Browsing was causing the problem and after turning it off I contacted their support who informed me that they're working on a fix for this issue and will be releasing it in the next 10 days.

Which is a fat lot of good for all their unsuspecting customers whose computers stop working as they will be blissfully unaware that this is due to their security being at fault

more options

Thanks to you all for helping me realise what the cause of the problem may be but please can someone tell me how to turn off the safe browsing option? Thanks a lot.