This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn't solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter and/r/firefox on Reddit.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Do I need to uninstall previous version of Firefox before installing new version?

  • 1 reply
  • 16 have this problem
  • 58 views
  • Last reply by TonyE

more options

I am worrried about installing new version (3.6.13 ) since old version (3.0.15) is working o.k. Can you advise?

I am worrried about installing new version (3.6.13 ) since old version (3.0.15) is working o.k. Can you advise?

Chosen solution

When you install a release version of Firefox (current version is 3.6.15), it will by default replace the existing version. There is no need to uninstall the old version first.

Read this answer in context 👍 14

All Replies (1)

more options

Chosen Solution

When you install a release version of Firefox (current version is 3.6.15), it will by default replace the existing version. There is no need to uninstall the old version first.