X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to add system-wide preferences in RHEL that will take effect for all profiles.

Posted

I have used the following docs to try to accomplish my task: https://developer.mozilla.org/En/A_Brief_Guide_to_Mozilla_Preferences https://developer.mozilla.org/en/Automatic_Mozilla_Configurator/Locked_config_settings

I wish to add proxy settings for all users, including those who already have profiles. I have tried adding to greprefs/all.js directly, using a mozilla.cfg file, all exactly as in the documents. But none of these things make a difference. Any more quidance would be SO appreciated!

I am using the latest RHEL5.5 and 3.6.13.

Chosen solution

See http://kb.mozillazine.org/Locking_preferences

Using mozilla.cfg in the Firefox program directory should work.

Did you use a byte shift of 13 to encode mozilla.cfg?

What is the content of the not encoded mozilla.cfg?

Read this answer in context 0

Additional System Details

This started when...

Started trying this on Fri 12/10

Installed Plug-ins

  • ICA Plugin (Linux) Version 10.6.115659 (/usr/local/ICAClient/current/wfica)
  • The next generation Java plug-in for Mozilla browsers.
  • Shockwave Flash 10.1 r85
  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • The default plugin handles plugin data for mimetypes and extensions that are not specified and facilitates downloading of new plugins.

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

Application Basics
Name
Firefox
Version
3.6.13
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Aspator
1.0252
true
HQ_IP@astri.org
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage
about:plugins
browser.startup.homepage_override.mstone
rv:1.9.2.13
extensions.lastAppVersion
3.6.13
network.cookie.prefsMigrated
true
places.last_vacuum
1291673254
privacy.sanitize.migrateFx3Prefs
true

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Chosen Solution

See http://kb.mozillazine.org/Locking_preferences

Using mozilla.cfg in the Firefox program directory should work.

Did you use a byte shift of 13 to encode mozilla.cfg?

What is the content of the not encoded mozilla.cfg?

Question owner

Thanks for your quick response! I am trying the unencoded mozilla.cfg, adding these 2 lines to my all.js:

pref("general.config.obscure_value", 0);

pref("general.config.filename", "mozilla.cfg");

Here is my top-level mozilla.cfg:

//BEGIN CE prefs

 // Proxy config
    defaultPref("network.proxy.autoconfig_url", "http://10.10.10.10:8080/");
    defaultPref("network.proxy.backup.ftp", "");
    defaultPref("network.proxy.backup.ftp_port", 0);
    defaultPref("network.proxy.backup.gopher", "");
    defaultPref("network.proxy.backup.gopher_port", 0);
    defaultPref("network.proxy.backup.socks", "");
    defaultPref("network.proxy.backup.socks_port", 0);
    defaultPref("network.proxy.backup.ssl", "");
    defaultPref("network.proxy.backup.ssl_port", 0);
    defaultPref("network.proxy.ftp", "10.10.10.10");
    defaultPref("network.proxy.ftp_port", 8080);
    defaultPref("network.proxy.gopher", "10.10.10.10");
    defaultPref("network.proxy.gopher_port", 8080);
    defaultPref("network.proxy.http", "10.10.10.10");
    defaultPref("network.proxy.http_port", 8080);
    defaultPref("network.proxy.no_proxies_on", "localhost, 127.0.0.1, cos.net, utmc.utc.com, doc, doc-test, scroll, scroll-test, scroll-dev, gumby, casey, crib, asic, topsweb, spiderweb,  spiderweb-test, ouray, ouraydev");
    defaultPref("network.proxy.share_proxy_settings", true);
    defaultPref("network.proxy.socks", "10.10.10.10");
    defaultPref("network.proxy.socks_port", 8080);
    defaultPref("network.proxy.ssl", "10.10.10.10");
    defaultPref("network.proxy.ssl_port", 8080);
    defaultPref("network.proxy.type", 1);

Modified by astandish

Question owner

Cor-el! Your document link led me to the fix. It specifically said not to use greprefs/all.js if the file in not encoded. So I put those 2 lines in default/pref/local-settings.js and it now works. Add a notch to your toolbelt! Thanks very much!