X
Tap here to go to the mobile version of the site.

Support Forum

How do you turn on the do not track feature?

Posted

According to an article in USA Today, Firefox has a "do not track" feature that keeps third parties for knowing what sites I visit. How do you turn this on?

According to an article in USA Today, Firefox has a "do not track" feature that keeps third parties for knowing what sites I visit. How do you turn this on?

Additional System Details

Installed Plug-ins

  • 6.0.12.775
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 8.2.5
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729)

More Information

davewdan 3 solutions 129 answers

Go to Tools|Options|Privacy and uncheck "Accept third-party cookies.

You may also want to install the add-ons "Ghostery" and "Better Privacy."

Ghostery detects and blocks tracking cookies. Better Privacy does the same for Macromedia flash cookies.


davewdan

Go to Tools|Options|Privacy and uncheck "Accept third-party cookies. You may also want to install the add-ons "Ghostery" and "Better Privacy." Ghostery detects and blocks tracking cookies. Better Privacy does the same for Macromedia flash cookies. davewdan
arbn 0 solutions 1 answers

Helpful Reply

From within "Options", go to "Advanced", and under the "General" tab check "Tell web sites I do not want to be tracked". That is the feature they are talking about, and it is only available in Firefox 4.

From within "Options", go to "Advanced", and under the "General" tab check "Tell web sites I do not want to be tracked". That is the feature they are talking about, and it is only available in Firefox 4.

Modified by arbn

AlFeldzamen 0 solutions 1 answers

Firefox 4.0.1 doesn't seem to have an "Options" choice under TOOLS. What now?

Please advise. alfeld@twcny.rr.com

Firefox 4.0.1 doesn't seem to have an "Options" choice under TOOLS. What now? Please advise. alfeld@twcny.rr.com
jasminetea 0 solutions 1 answers

You're probably using it on a Mac, like me? Go to File > Preferences.

You're probably using it on a Mac, like me? Go to File > Preferences.
TonyE
  • Moderator
1044 solutions 8863 answers

AlFeldzamen, if using the new style UI, click the orange Firefox button on Windows or grey Firefox button on Linux, you can then click on Options/Preferences.

AlFeldzamen, if using the new style UI, click the orange Firefox button on Windows or grey Firefox button on Linux, you can then click on Options/Preferences.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Helpful Reply

Note that selecting that do-not-track setting will only make Firefox send a specific HTTP header (DNT=1) to a web server. It is up to the server to do something with that request.

Firefox (Tools) > Options > Advanced > General: "Tell web sites I do not want to be tracked"

  • privacy.donottrackheader.enabled -> Header: HTTP_DNT: 1
Note that selecting that ''do-not-track'' setting will only make Firefox send a specific HTTP header (DNT=1) to a web server. It is up to the server to do something with that request. [http://kb.mozillazine.org/Menu_differences Firefox (Tools) > Options] > Advanced > General: "Tell web sites I do not want to be tracked" * privacy.donottrackheader.enabled -> Header: HTTP_DNT: 1 * http://blog.sidstamm.com/2011/01/opting-out-of-behavioral-ads.html * http://blog.sidstamm.com/2011/01/try-out-do-not-track-http-header.html * http://browserspy.dk/donottrack.php
sukant 0 solutions 3 answers

If you want to activate in Firefox 5 ,just go to option>privacy> tell websites i do not want to be tracked

if you to activate in Firefox 4 ,just go to option > advanced > browsing > tell websites i do not want to be tracked (mark it )

If you want to activate in Firefox 5 ,just go to option>privacy> tell websites i do not want to be tracked if you to activate in Firefox 4 ,just go to option > advanced > browsing > tell websites i do not want to be tracked (mark it )
WebHybrid 0 solutions 11 answers

The option “Tell web sites I do not want to be tracked” is grayed out in my Firefox 6.02. (See screen capture.) Anyone know how to make it available?

The option “Tell web sites I do not want to be tracked” is grayed out in my Firefox 6.02. (See screen capture.) Anyone know how to make it available?
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Maybe an extension is locking that setting (preference="privacy.donottrackheader.enabled").

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Maybe an extension is locking that setting (preference="privacy.donottrackheader.enabled"). Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.com/kb/Safe+Mode
WebHybrid 0 solutions 11 answers

Thanks cor-el.

Without using the Safe Mode, after my earlier post, I searched through about:config using the term track. This reminded me, I have the add-on called DoNotTrackPlus 1.0. Its description showing in the Add-ons Manager is: "Take control over the DoNotTrack header," which could account for the graying out of the built-in option.

My about:config search results are in the screen cap below, and the two indicated entries - one with value false and the other with true - would seem to support the idea that the add-on has replaced the built-in function. If I'm right, then nothing is really wrong here??

Also, wouldn't this account for the anti-malware Super AntiSpyware always finding the same set of "tracking cookies" when I do an on-demand scan? I remove the cookies and then they're back the next time... these would be "do not track" cookies generated by the add-on every time the browser launches? (Eventually I unchecked Super AntiSpyware's option to look for tracking cookies.)

Thanks cor-el. Without using the Safe Mode, after my earlier post, I searched through about:config using the term ''track''. This reminded me, I have the add-on called '''DoNotTrackPlus 1.0'''. Its description showing in the Add-ons Manager is: "Take control over the DoNotTrack header," which could account for the graying out of the built-in option. My about:config search results are in the screen cap below, and the two indicated entries - one with value '''false '''and the other with '''true''' - would seem to support the idea that the add-on has ''replaced ''the built-in function. If I'm right, then nothing is really wrong here?? Also, wouldn't this account for the anti-malware '''Super AntiSpyware''' always finding the same set of "tracking cookies" when I do an on-demand scan? I remove the cookies and then they're back the next time... these would be "do not track" cookies generated by the add-on every time the browser launches? (Eventually I unchecked Super AntiSpyware's option to look for tracking cookies.)