X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox not saving tabs on shutdown when prompted to

Posted

Recently firefox asks do I want to save and quit, I select yes and then when I restart the computer, they are not up.

Chosen solution

This can be a problem with the file sessionstore.js in the Profile Folder

Delete the files sessionstore.js and sessionstore.bak and any existing files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js .

See http://kb.mozillazine.org/Session_Restore

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

If you use Remove recent browsing, search and download history in Firefox 3.5 and later to clear the 'Browsing History' when you close Firefox then restoring tabs from the last session ("Save & Quit" or "Show my windows and tabs from last time") doesn't work.

Question owner

Well, that is certainly not something I am *actively* doing, and the only change in my " security" systems is using spy bot to immunize after running a scan. Even so, I've been immunizing for a couple of weeks, but this problem only stated yesterday. I am not particularly computer savvy....

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

Chosen Solution

This can be a problem with the file sessionstore.js in the Profile Folder

Delete the files sessionstore.js and sessionstore.bak and any existing files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js .

See http://kb.mozillazine.org/Session_Restore

Question owner

That was it! Thank you so much!

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

You're welcome

RickK 0 solutions 2 answers

My tabs won't save either. (XP, Firefox 3.6.10)

Options-General-Startup says to restore tabs. I've turned it off and back on, but that didn't help.

Options-Tabs-WarnMeWhenClosingMultipleTabs is checked. I've tried it both ways.

sessionstore.js is created when Firefox starts, and goes away at Firefox shut-down. I don't see any other sessionstore*.* files.

My tabs don't get restored.

I get no warning about multiple tabs at Firefox shut down.

No other Firefox windows are open.

Thanks, Rick

Modified by RickK

RickK 0 solutions 2 answers

Helpful Reply

Thanks cor-el. That did it!

I didn't think that I was using private browsing, but the settings belonging to "Clear history when Firefox closes" were the problem.

I appreciate your assistance,

Rick

kkay 0 solutions 4 answers

I am using 3.6.13 version for Win7 64 bit. I started getting this problem once Firefox updated my browser yesterday. One time earlier when I clicked save tabs, it worked. The next time it did not. I do not have clear history when Firefox closes selected.

jwh7 1 solutions 5 answers

Helpful Reply

I've had this issue (or similar) several times, in FF3.6 and also 3.5 and 3.0. All the typical suggestions were no help; deleting the session, checking tabs options and about:config, private browse settings, and un-/re-installing FF. I forgot now if the specific issue was that the 'Save and Quit' dialog doesn't popup; or if it does, but 'Save and Quit' would not save the tabs for the next session. Anyway, hopefully this will help some of you.

The thing that fixed my issue (and this has occurred several times), I found in a couple obscure google searches. Instead of using the upper-right-corner 'X' to close the window; instead go to File (alt-F if you have your menu hidden) -> 'Exit'. Sounds ridiculous, I know; seems like it was related to upgrading b/t major versions (and I've seen a bunch of these posts popup relating to FF4 upgrades now). I've only done fresh installs of FF4 beta, and not seen the issue. Looks like FF4 has added a new config option: browser.showQuitWarning, that would be something else to check.

I thought I'd sent in a mozilla bug report on it, along w/ replying to a few support forum entries, but now I can't find anything relating to it.

To summarize the various things to check with this issue:

1. Check the Options -> Tabs for 'Warn me when closing multiple tab'

2. Check about:config for the above and similar entries (search for 'warn' and 'quit')

3. Check the Options -> Privacy that Private Browsing isn't enabled (or just select 'Remember History' [note-I think this selection doesn't stay; it just changes the underlying options; can be confusing]

4. Simply go to File -> Exit, instead of the upper-right corner 'X' to close

5. Un-/Re-install FF

6. Delete your sessions file [search elsewhere for details]

I'll be copying this to other forum entries...

Modified by jwh7

coopster 0 solutions 1 answers

I was having this problem but Session Restore did not work for me. I found that I had to change a setting in my options.

  • Firefox > Options
  • General tab
  • When Firefox starts: Show my windows and tabs from last time

That's all it took. Now my Tab Groups are saved and my session is restored every time.

Modified by coopster

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

App (pinned) tabs and Tab Groups (Panorama) are stored as part of the session data in the file sessionstore.js in the Firefox profile folder.

Make sure that you do not use Remove recent browsing, search and download history to clear the "Browsing History" when Firefox is closed because that prevails and prevents Firefox from opening tabs from the previous session.


Firefox 4 saves the previous session automatically, so there is no longer need for the dialog asking if you want to save the current session.
Use "File > Exit" or "Firefox > Exit" if you want to restore multiple windows.
You can use "Firefox > History > Restore Previous Session" to get the previous session at any time.
There is also a "Restore Previous Session" button on the default about:home Home page.

Atrinoisa 0 solutions 1 answers

FINALLY, something that actually works! Thank you jwh7! Seems stupid that I'm going to have to close out like that now...but as longs as it works I guess...

All my settings are correct...I never changed them and wasn't having any problems before Mozilla decided to change the stupid tabs so you had to hit a restore button that never pops up for me....and the one under history is always grayed out for me! Just brilliant.