Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

when typing in location bar, I have to type the URL, not just keywords...I want to change this. Please help!

  • 2 replies
  • 3 have this problem
  • Last reply by cor-el

more options

I want to be able to type keywords in the location bar. When I do that and press Enter, it says "URL is not valid"

All Replies (2)

more options

A couple of preferences to check:

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. In the filter box type keyword
  4. If the preference keyword.enabled is set to false double-click on it to change it to true
  5. Right-click on the preference keyword.URL and choose Reset (if it is already using the default Google option, Reset will not be available)

For more details see Search the web from the address bar.

Modified by TonyE

more options