Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why the pop-up message "ERROR" when I have the latest version of Java and Firefox?

  • 14 replies
  • 267 have this problem
  • 3 views
  • Last reply by zambolis

more options

I have the latest version of both Java and Firefox. When I opened an Advanced Oxford Learner's Dictionary the pop-up has a message "Your Java plug-in requires Mozilla Firefox 3 or latest". I do not understand why this message pop-up?

All Replies (14)

more options

Unfortunately your post does not include the user agent string which shows the version of Firefox being reported, or the list of plugins which helps in diagnosing this problem.

Your useragent string which identifies your browser may be wrong. If you go to Help > About Mozilla Firefox it will show your useragent string, it should look similar to this: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

If it does not, try the following:

  1. Type about:config into the location bar and pres enter
  2. Accept the warning message, and a list of preferences will appear
  3. In the filter box type general.useragent
  4. If any have a status shown as user set right click on it and choose Reset

To confirm you have the latest version of Java, go to http://java.com/en/download/installed.jsp and click on the Verify Java version button, it should tell you that you have Version 6 Update 21

more options

you are probably running a 64bit windows version with 64bit java installed; you need to install the 32bit java version under Program Files (x86) which should solve the problem.

more options

The Java installed in my machine is 32bit(x86). The problem still persists.

more options

Can you post your Help > Troubleshooting Information data in a code block (<pre>...</pre>)?

See Use the Troubleshooting Information page to help fix Firefox issues

more options

Look here: http://pearsonsupport.helpserve.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=301

If you cannot open it, here is the text from the site. It is about a different dictionary, but the folder structure is the same. I have replaced the folder names as appropriate.

It worked for me. I hope it works for you, too.

=================

Java plug-in error message


SolutionProduct:Longman Dictionary of Contemporary English (Updated edition)=-===- (works for Oxford Advanced 7th Ed, too). ISBN:-- Category:CD-ROM User Type:Windows users Item:Java plugin error message Some users of LDOCE updated will experience the following error message:

The new Java Plug-in requires a recent version of the Firefox browser (Firefox 3 or later).

This error message is caused by an incompatibility between OALD7 updated and Java 6 update 21. Please try the following steps to update your product:

1.Download and extract the patch file (http://www.longmanproductsearch.com/uk-support/downloads/java_winpref.zip). 2.Open Windows Explorer and browse to the dictionary installation directory (typically C:\Program Files\Oxford\OALD7). 3.Browse into the "defaults" folder, then the "prefs" folder. 4.Rename the file "winpref.js" to "winpref.js.old". 5.Copy the extracted file from step 1 into the same directory. Now when you run OALD7 updated, it should work fine.

=====================================

That's it.

Enjoy!

Modified by cor-el

more options

Privremero, Thank You very much. This post is the best solution for the above problem. I tried and it works sucessfully.

more options

i had oxford dictionary cd and i install this after 3 year gap this type of problem came i also chage oald7.exe by renamed file mozilla.exe by oald7.exe this solves my problem to some extent. woh but this solution is very good solve all problems in one

Modified by sumit103

more options

Thanks! privremeno.Your solution worked. Also I would like to tell people that the url on site presented me to download the most matching file It found and it worked.

Modified by hibuddy.sourabh

more options

could any upload the patch somewhere else, It seems that the link has expired

more options

The following is the original post of Privremero:


Look here: http://pearsonsupport.helpserve.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=301

If you cannot open it, here is the text from the site. It is about a different dictionary, but the folder structure is the same. I have replaced the folder names as appropriate.

It worked for me. I hope it works for you, too.

=====

Java plug-in error message


SolutionProduct:Longman Dictionary of Contemporary English (Updated edition)=-===- (works for Oxford Advanced 7th Ed, too). ISBN:-- Category:CD-ROM User Type:Windows users Item:Java plugin error message Some users of LDOCE updated will experience the following error message:

The new Java Plug-in requires a recent version of the Firefox browser (Firefox 3 or later).

This error message is caused by an incompatibility between OALD7 updated and Java 6 update 21. Please try the following steps to update your product:

1.Download and extract the patch file (http://www.longmanproductsearch.com/uk-support/downloads/java_winpref.zip). 2.Open Windows Explorer and browse to the dictionary installation directory (typically C:\Program Files\Oxford\OALD7). 3.Browse into the "defaults" folder, then the "prefs" folder. 4.Rename the file "winpref.js" to "winpref.js.old". 5.Copy the extracted file from step 1 into the same directory. Now when you run OALD7 updated, it should work fine.

=========================

That's it.

Enjoy!



+++++++++++++++++++++++++++++++
+++++++++++++++++++++++++++++++
+++++++++++++++++++++++++++++++
The link to the patch as mentioned before is not available anymore. Here is a new link:
http://www.filesonic.in/file/1754849854

Modified by cor-el

more options

The Patch can be downloaded from:
http://www.filesonic.in/file/1754849854

Modified by cor-el

more options
more options

Where is the patch file? I cant find it from anywhere. please help.

more options

NimaRazavi, just click the link posted by nyrygyk and downloaded the patch in number 1. Hope it helps!