X
Tap here to go to the mobile version of the site.

Support Forum

When trying to download firefox 3.6 (currently using firefox2) an error message defective image 3.6.8 appears and the upgrade fails?

Posted

Currently using firefox 2, need to upgrade to 3.6 but computer keeps saying defective image 3.6.8 and cannot activate upgrade?

This happened

Every time Firefox opened

Currently using firefox 2, need to upgrade to 3.6 but computer keeps saying defective image 3.6.8 and cannot activate upgrade? == This happened == Every time Firefox opened

Additional System Details

Installed Plug-ins

  • -Netscape Navigator Default Plug-in
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Shockwave Flash 9.0 r47
  • Shockwave Flash 9.0 r16
  • Java 1.3.1 Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers
See http://kb.mozillazine.org/Installing_Firefox The most recent Firefox version for OS X 10.3.9 is 2.0.0.20. Mac: http://download.mozilla.org/?product=firefox-2.0.0.20&os=osx&lang=en-US http://www.mozilla.com/en-US/firefox/system-requirements.html - Mozilla Firefox 3.6 System Requirements