X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox 3.6.8 does not recognize subsequent mouseclicks - window loses focus

Posted

After updating to firefox 3.6.8 on my macbook pro (OS X 10.4.11) Firefox fails to recognize subsequent mouse clicks. You can access the page initially, but then it seems to lose focus and become unresponsive to mouse clicks until you do something to break the cycle (clicking on desktop, minimizing and resizing window, etc). I reinstalled Adobe Flash update using full installer, since others have suggested that as a possible cause, but no joy. The browser window still does not recognize mouseclicks after an initially successful page load. You can tab to the next window (for example, if you want to enter something in search) but you cannot CLICK to enter the search window, nor can you click on links on the page, etc. It is totally unresponsive.

This happened

Every time Firefox opened

== I updated Firefox to the version just before 3.6.8 -- then I updated to 3.6.8 to see if that fixed it -- it's still broken

Additional System Details

Installed Plug-ins

  • -Cooliris embbedded in a tab
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Gecko default plugin
  • Picasa plugin.
  • npmnqmp 071505000006
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6
  • Yahoo! Installer Plug-in provides application installation support
  • JoostPlugin plug-in
  • RealPlayer Plugin
  • 3.0.40818.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.7
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r53

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

*-Cooliris embbedded in a tab
*Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
*Gecko default plugin
*Picasa plugin.
*npmnqmp 071505000006
*The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
*iPhoto6
*Yahoo! Installer Plug-in provides application installation support
*JoostPlugin plug-in
*RealPlayer Plugin
*3.0.40818.0
*Adobe Shockwave for Director Netscape plug-in, version 11.5.7
*The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
*Shockwave Flash 10.1 r53

Question owner

just more info regarding the above -- disabled add ons - no luck. Disabled plug ins - no luck. Disabled autoscrolling - no luck. This makes the browser almost impossible to use. You cannot place the mouse cursor within a field (unless you click TAB first to break the cycle). You cannot click on sequential items on a page. Clicking on desktop then back to firefox sometimes reenables the mouseclick, but not always.

Can we revert back to an earlier version of Firefox, or do we need to abandon it completely until this is fixed?

Question owner

Removing all add-ons (I was using Cooliris, webmonkey, video downloader)l reinstalling Flash with full installer, not slim updater did not seem to work -- I also disabled Move networks Quantum media player plug ins, which i did not even know was on my system. Not sure where that came from! Also turned off Audio hijack application. Then I did a complete restart of the computer (not just a restart of Firefox) and that seems to have done the trick. Not sure which, if any of the above add-ons or apps was the culprit, but the complete restart is highly recommended if you are experiencing similar mouse issues. Will repost if it happens again.

alcapone69 0 solutions 1 answers

Helpful Reply

This started happening to me yesterday. All plugins are disabled, didn't help. All plugins uninstalled, didn't help. Downgraded to SP3, didn't help. I've also noticed this happen in Thunderbird, though it seems OK now.

Sadly I've had to start using IE8 :(

firuseforever 0 solutions 1 answers

It's simple. The scroll button on your mouse must be stuck/depressed. Try releasing it or tapping it and then you will have all clickable links in Firefox.

The centre mouse is the culprit.

spow 0 solutions 2 answers

Yes - this is very debilitating. WinXp Pro

Workstation at work. Once Firefox "fouls", it is like it has lost focus yet is still the topmost window. The only firefox controls that receive focus and are "clickable" by the mouse are the "File, Edit....Help" menu. Not even the actual minimize, maximize & close windows buttons can be selected by the mouse. Nothing (hyperlinks, buttons, etc) on a web page can receive focus from the mouse.

Ctrl-Tab to another app and back...all is well until "something" fouls it again. might be the next click or 20 clicks down the road.

Strangely also seems to cause Excel '97 where once fouled (and regardless of Ctrl-Tab), excel behaves like the shift key is stuck down. endless selecting cells....nothing can by entered using the keyboard.

My laptop is fine. probably very close set of add-ins. mouse driver?

I see both a Logitech USB driver and a MS PS2 driver installed under the device manager. I am using a Logitech Wheelmouse - with a PS2 connection.

spow 0 solutions 2 answers

Finally plugged a newer USB Logitech mouse in (incorrectly stated my old mouse was PS/2 but it was USB as well) and rebooted and the problem has not occurred in hours. Pretty sure it's ok now....touch wood!

Replaced M-BD58 Logitech mouse with M-UV55a. I didn't change/install any drivers.

massivac 0 solutions 3 answers

I also have similar problem with firefox. No solutions found as yet. Have been using Firefox for the last 8 years, but for the last few years firefox has been usine too many of resources and slowing down my speed. But this latest losing focus thing is a bit too much.

I guess it would be better to start using faster browsers........:(

But I rather use Firefox, please............but how?

n8vzl 0 solutions 1 answers

I am using Firefox 10.0 and same problem. I will try another mouse.

adragon 0 solutions 1 answers

It's not the mouse. Because it happened to me and I didn't have a scroll button on two of the four "mouses'. It happened on all, same way. Solution: 'option + command + esc' on mac. Open force quit window. Firefox then recognizes my mouse, without having to quit, simply close the force quit window.