X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I get error about invalide security certificate

Posted

I have a problem with certificate , every time i visit secure sites like yahoo, paypal, alertpay ... ect. i get this error : You have asked Firefox to connect securely to www.paypal.com, but we can't confirm that your connection is secure. After i add the site to the exception list i get this error : The certificate is not trusted because is self-signed. I film the brownser to be easy for you to understand , hir is the link : http://hotfile.com/dl/41402461/129b610/5-4-2010_11-28-22_PM.avi.html

This happened

Not sure how often

== relly i don't know , i think a week ago

Additional System Details

Installed Plug-ins

  • -Office Plugin for Netscape Navigator
  • 1.9.0009.1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Foxit Reader Plug-In For Firefox and Netscape
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.0 r42
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • GEPlugin
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Download Statusbar
0.9.6.8
true
Download Youtube Videos +
2.1.3
true
video.downloader.plugin@ffpimp.com
DownThemAll!
1.1.9
false
Forecastfox
0.9.10.2
true
{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
Java Quick Starter
1.0
true
jqs@sun.com
Microsoft .NET Framework Assistant
1.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Sothink SWF Catcher
1.3.2
true
Java Console
6.0.16
true
Java Console
6.0.17
true
Java Console
6.0.20
true
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.google.ro/
browser.startup.homepage_override.mstone
rv:1.9.2.3
browser.tabs.warnOnClose
false
extensions.lastAppVersion
3.6.3
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
places.history.enabled
false
places.history.expiration.transient_current_max_pages
60377
places.last_vacuum
1270727715
privacy.sanitize.migrateFx3Prefs
true
security.OCSP.disable_button.managecrl
false
security.default_personal_cert
Select Automatically
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_entering_weak
false
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate. You can click the link at the bottom of the error page: "I Understand the Risks" Make Firefox retrieve the certificate: "Add Exception" -> "Get Certificate". Click the "View..." button to inspect the certificate and check who is the issuer. Only leave the mark in the box at the bottom to "Permanently store this exception" if you trust that certificate. Click "Confirm Security Exception" to enter the site if you still want to go to that website. If the issuer is your security software then you either have to disable that check in your firewall or install the root certificate of that firewall. See Configure firewalls so that Firefox can access the Internet

Question owner

yes , thanks for the answer , its seem that the Windows firewall is the problem, but i add FireFox to Firewall exception list and still i have the problem.



p.s. i don't want to turn off Windows firewall

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox.

See Configure firewalls so that Firefox can access the Internet and http://kb.mozillazine.org/Firewalls

Question owner

I find the real problem, its web protection at Karspesky 7 , and it don't have an exception list like karspesky internet security , its have trusted URLs , i add some of them , i restart FireFox but still i have the problem Please help me

ldmuse 0 solutions 1 answers

I turned off my Windows firewall but continue to get the message. The error message says Firefox is issuing the error message. Makes me want to go back to IE