Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Delayed browser start after version 107 update

  • No replies
  • 1 has this problem
  • 9 views
more options

I've noticed that for the last few days, Firefox takes several seconds to start. I happened to look in settings while I have the spinning ball and waiting for it to start, and noticed that the "Checking for updates" is running. The moment that it verifies Firefox is up to date, my initial browser page opens with my default page. It looks like version 107 was installed on Nov 15th, which is just about the time I noticed this problem occurring.

Is there any fix for this or is that something I have to live with until enough people notice it as a problem and a new update is released? Using Windows 10 if that makes any difference.

Thanks for any help from any of you.

I've noticed that for the last few days, Firefox takes several seconds to start. I happened to look in settings while I have the spinning ball and waiting for it to start, and noticed that the "Checking for updates" is running. The moment that it verifies Firefox is up to date, my initial browser page opens with my default page. It looks like version 107 was installed on Nov 15th, which is just about the time I noticed this problem occurring. Is there any fix for this or is that something I have to live with until enough people notice it as a problem and a new update is released? Using Windows 10 if that makes any difference. Thanks for any help from any of you.