Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem Setting Firefox as Default Browser

  • 3 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

Windows 10 Home 21H1 (in Korean Environment) Firefox Developer Edition 92.0b5 (64-bit), installed in "D:\Program Files\Firefox Developer Edition", linked directory "C:\Program Files\Firefox Developer Edition" to installed path

1. When I choose the default browser app in Windows settings, It displays Firefox twice.

2. I selected either of them as default browser, but Firefox settings displays that it's not selected as default browser. And also "set as default browser" button does not work

How can i solve this problem?

Attached screenshots

All Replies (3)

more options

It's possible you have two versions of the program.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files . C:\Program Files (x86) Note: Check Both Folders


more options

FredMcD #answer-1436807

I did NOT install 2 versions, I installed at D: drive, and created directory shortcut using "mklink" command in cmd.exe at "C:\Program Files"

Modified by horai3420


more options

I don't know how that works.

You should try asking here:


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.