Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search results says Phrase not found whenit shouldbe found

  • 6 replies
  • 1 has this problem
  • 12 views
  • Last reply by joseibarra

more options

I have noticed since Firefox 89.0.2 that when I press Ctrl-F to search a page it seems to work for a while but eventually stops working resulting in Phrase not found - but I know the phase is on the page.

I think if I restart my system it works sometimes for a while and later quits working but don't know how many times it works before it quits or what happens to make it quit working but it doesn't last long.

I have already done all the clear caches, history etc. and think if I totally restart my system that gets it working again for a while.

If I copy/pate the same URL into Chrome and perform the same search the phrase is found every time without fail.

Since I use the search frequently I don't think it was a problem in versions before 89.0.2 or I would have noticed it.

Attached screenshots

Chosen solution

You need to remove the checkmark on "Whole words" to make Firefox find '125' since this is part of a word: 'EP-125NK'.

Read this answer in context 👍 0

All Replies (6)

more options

About how long was the browser running when you notice this? Have you noticed this with the same search on the same page?

Sometimes, what you think is text on a webpage is really a picture.


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Helpful?

more options

I have restarted my system and when I visit this link:

link text

Then using Chrome I press Ctrl-F for search for 125 it finds 1/4 hits which is right and this works everytime.

I paste that link into Firefox, press Ctrl-F and search for 125 it reports Phrase not found.

I restarted Firefox in Troubleshoot Mode and get the same results.

What happens when you try it?

Helpful?

more options

No problems here.

The Find bar has find settings for "Highlight All" and "Whole Words" and "Match Case" that are hidden when you use Quick Find. So open the Find bar via Ctrl+F and check these choices. Related prefs as found on the about:config page.

  • findbar.highlightAll
  • findbar.entireword (false)
  • findbar.matchdiacritics (false)
  • accessibility.typeaheadfind.casesensitive (0/1)

Helpful?

more options

My Find Bar looks like the attached image.

My Config looks like that attached image.

I know this worked before I installed 89.0.2 since if it didn't work before that I would have known about it a long, long time ago. I use the search all day long and now it doesn't work.

Now that you see the settings what do you suggest changing and what is wrong with the way things are now?

I suppose there is no easy way to roll back to a previous version for testing?

I needed 89.0.2 to get the "Get Image Info" option when was removed in the previous version whatever that was - I don't remember what it was before.

Helpful?

more options

Chosen Solution

You need to remove the checkmark on "Whole words" to make Firefox find '125' since this is part of a word: 'EP-125NK'.

Helpful?

more options

That seems to work!

Thanks.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.