Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Connection has timed out" for every website in Firefox, not other browsers

  • 3 replies
  • 1 has this problem
  • 9 views
  • Last reply by Scribe

more options

Hey everyone,

since some time now, Firefox on my laptop won't load any websites. When I click on on of my bookmarks or type in a URL, it first starts loading forever and eventually gives me the "Connection has timed out" error. This happens for every website, but only in Firefox. Other browsers like Chrome or Edge do not have this problem. I re-installed Firefox and deleted all files related to it manually (in appdata and programms folders) to make sure everything is gone. After a fresh re-install, it worked for a while, but then stopped working again. I don't know what caused this. I have also tried every step explained on this website already: https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

My Firefox version is 83.0 and my Windows version is Windows 10 Home, Version 10.0.18363 Build 18363.

I would greatly appreciate your help! Thanks, Tim

All Replies (3)

more options

Helpful?

more options

FredMcD said

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own. ...

Hey FredMcD,

thanks for the help, but there is no security software installed (other than Windows' own security features). This also didn't change between the time when it worked and when it didn't.

Helpful?

more options

Hi, hold down the Shift key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.


If that doesn't help, open the 3-bar menu > Add-ons > Plugins, and to test, using the 3-dot (...) menu to the right of each one, set 'Honey,' 'AdBlocker Ultimate,' 'LastPass' and 'Library Access' to Never Activate, then restart Firefox.

If it works, activate them one by one and restart Firefox each time until you find the culprit.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.