Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube keeps wanting to go to a different application, then says the address is invalid

more options

YouTube doesn’t work. Every time I try to play a video it say would you like to go to (insert insanely long URL here) and when I press ok, it says the address is invalid. I have gone through the settings and restarted the phone but nothing works.

All Replies (9)

more options

From other responese, it appears the culprit is an extension. See if this solution works for you.

After the last update my youtube home page redirects to random channels.

more options

clicked the link and it took me to the create a new article page...

more options

Well dang. I assumed the link was correct. It appears the page no longer exists. Let's try this post.

Going to YouTube with Firefox, it will redirect me from the Home page, to a random suscription page.

more options

Same thing happens. Would screenshots of the YouTube problem possibly help find a working forum to answer the problem?

Modified by Joshua Terry

more options

Let's try one more URL. This one works for me.

https://support.mozilla.org/en-US/que.../1286268

more options

I don’t have any extensions and the other tips didn’t work. I will attach some screenshots of what happens to see if that helps to narrow it down.

more options

Another one:

more options

Sorry, Joshua. I'm not sure where to go from here. I tried a number of things and was unable to duplicate your issue on my iPhone X or Macbook. Can you share the link you're trying to open?

EDIT: Reading your original post again, I assume every link you attmept to open doesn't work, so sending one won't help.

Modified by OBW47

more options

Every video on YouTube have the same problem.