Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Stop opening in tabs

  • 5 replies
  • 1 has this problem
  • 9 views
  • Last reply by sonnyboy1

more options

As of today, 04/09/20, every time I highlight something and then right click menu to search yahoo for whatever I highlighted. Before it always did the search in a new window. Now, today, when I click 'search yahoo for', it opens in a tab. I have the 'no tabs' add-on which has always worked great. I may be one of few, but I hate tabs. So, the tabs are at the top of the screen and when I click x in the top right corner I get the dreaded 'You are about to close 3 tabs' 'Are you sure you want to continue'. I put 3, but it could be 2, 3, 4 or whatever. Not sure what happened overnight and nothing shows in Event Viewer' that would cause this. Any ideas or solutions?

Attached screenshots

Chosen solution

Hi sonnyboy1, can you try turning it off and on again. What I mean is:

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then scan down the right side to No Tabs. Click the blue "slider switch" to disable it, then click the switch again to re-enable it. Any improvement?

By the way, I created a similar extension back in 2018 (I Hate Tabs). Had I known about No Tabs, I might never have started my journey as an extension writer.

Read this answer in context 👍 1

All Replies (5)

more options

Go to about:config and take a look at "search" specifically I'm curious what you have browser.search.openintab set to

Helpful?

more options

Chosen Solution

Hi sonnyboy1, can you try turning it off and on again. What I mean is:

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then scan down the right side to No Tabs. Click the blue "slider switch" to disable it, then click the switch again to re-enable it. Any improvement?

By the way, I created a similar extension back in 2018 (I Hate Tabs). Had I known about No Tabs, I might never have started my journey as an extension writer.

Helpful?

more options

Eve said

Go to about:config and take a look at "search" specifically I'm curious what you have browser.search.openintab set to

Hi Eve, it's set to False.

Helpful?

more options

sonnyboy1 said

As of today, 04/09/20, every time I highlight something and then right click menu to search yahoo for whatever I highlighted. Before it always did the search in a new window. Now, today, when I click 'search yahoo for', it opens in a tab. I have the 'no tabs' add-on which has always worked great. I may be one of few, but I hate tabs. So, the tabs are at the top of the screen and when I click x in the top right corner I get the dreaded 'You are about to close 3 tabs' 'Are you sure you want to continue'. I put 3, but it could be 2, 3, 4 or whatever. Not sure what happened overnight and nothing shows in Event Viewer' that would cause this. Any ideas or solutions?

jscher2000 said

Hi sonnyboy1, can you try turning it off and on again. What I mean is: Open the Add-ons page using either:
  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return
In the left column of the Add-ons page, click Extensions. Then scan down the right side to No Tabs. Click the blue "slider switch" to disable it, then click the switch again to re-enable it. Any improvement? By the way, I created a similar extension back in 2018 (I Hate Tabs). Had I known about No Tabs, I might never have started my journey as an extension writer.

Helpful?

more options

It works, jscher. Thank you. It was driving me to distraction.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.