Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website with SSL that has been fine suddenly started showing the yellow triangle on the padlock even when a blank page is uploaded, no other browser shows this

  • 5 replies
  • 1 has this problem
  • 15 views
  • Last reply by peter175

more options

The address of the blank page is https://www.sirnigelgresley.org.uk/test.shtml which shows as fully secure in IE, Safari, Chrome and etc but in Firefox it has just started to show the yellow triangle on the padlock. This applies to the whole of the site on a desktop/laptop, but not on a mobile where largely the same files are used.

The coding on this page is just:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html lang="en">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii" />
<meta http-equiv="expires" content="now" />
<meta http-equiv="pragma" content="no-cache" />
<meta name="content-language" content="en-gb" />
<meta name="robots" content="all, index, follow, contents" />
<meta name="revisit-after" content="4 weeks" />
<meta name="title" content="Sir Nigel Gresley" />
<meta name="owner" content="Sir Nigel Gresley Locomotive Trust Ltd" />
<meta name="author" content="Brush House" />
<meta name="rating" content="general" />
<meta name="classification" content="Railways" />
<meta name="description" content="Sir Nigel Gresley Locomotive Trust Ltd, preservers of Gresley A4 Pacific 60007 'Sir Nigel Gresley'" />
<meta name="keywords" content="gresley, steam, locomotive, 4498, 7, 60007, sir, nigel, a4, pacific, preservation, trust, london, north, eastern, railway, british, railways, region" />
<title>LNER A4 pacific locomotive &#39;Sir Nigel Gresley&#39;</title>
</head>
<body>

</body>
</html>

Nothing else, so why the yellow triangle? Help!

Attached screenshots

Modified by cor-el

Chosen solution

I'm not seeing the special padlock icon on either.

You may have some outdated files in the disk cache.

You can possibly test this in a New Private Window.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Read this answer in context 👍 1

All Replies (5)

more options

It is possible that there is content on the page retrieved via an open HTTP connection, possibly images.

Did you click the padlock icon for more information ?

You can check in the Web Console for possible messages about mixed content.

more options

Thanks for your response and yes, I spent ages checking out the info from the padlock icon. This is really weird and I feel has to be something server-related. I have uploaded another completely empty file to both this site and another I maintain with the same hosting company.

https://sirnigelgresley.org.uk/Untitled.html shows the yellow warning triangle https://92squadron.co.uk/Untitled.html does not!

Exactly the same file though on different web sites hosted by the same provider.

The image Untitled1.png is the site where the problem is. The image Untitled2.png is exactly the same file on a different site. The image Untitled3.png shows the minimal amount of coding on this page.

more options

Chosen Solution

I'm not seeing the special padlock icon on either.

You may have some outdated files in the disk cache.

You can possibly test this in a New Private Window.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

more options

Many thanks for your input. I had tried loading the site on two different laptops, both running Firefox v71.0, and the problem appeared on each one which made me think that it might be something other than my own computer causing it to happen. I hadn't thought of trying in a private window but did that just now and everything showed as it ought to.

I'll try the "Forget about this site" and keep my fingers crossed. I'm quite curious to learn how this happened, but knowing the Internet, I probably won't. :-(

more options

Solved!

Many thanks for your advice - "Forget about this site" did the trick.

How odd, though, that this 'problem' should crop up on two different computers. Maybe down to having the same IP address?

Now to do the same on the other machine.