X
Tap here to go to the mobile version of the site.

Support Forum

When I block websites under "Managed Permissions" the cookies are still added. Why?

Posted

YouTube consistently reappears in my cookies despite the fact I have the website blocked. It seemingly does this when I am using google search, an unrelated function. I don't want websites that I block to be able to store cookies at all.

YouTube consistently reappears in my cookies despite the fact I have the website blocked. It seemingly does this when I am using google search, an unrelated function. I don't want websites that I block to be able to store cookies at all.

Chosen solution

When you spot a site you don't want storing cookies in the "Manage Data" dialog, for example:

youtube.com

Then you should mirror that host name when you create the exception, which needs to be in a protocol://hostname format. For example:

https://youtube.com

(and optionally)

http://youtube.com

Does that work?

Now, the site also uses Google cookies, but perhaps it's not practical to block those?

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

jscher2000
  • Top 10 Contributor
8880 solutions 72663 answers

Chosen Solution

When you spot a site you don't want storing cookies in the "Manage Data" dialog, for example:

youtube.com

Then you should mirror that host name when you create the exception, which needs to be in a protocol://hostname format. For example:

https://youtube.com

(and optionally)

http://youtube.com

Does that work?

Now, the site also uses Google cookies, but perhaps it's not practical to block those?

When you spot a site you don't want storing cookies in the "Manage Data" dialog, for example: '''youtube''.''com''' Then you should mirror that host name when you create the exception, which needs to be in a protocol://hostname format. For example: https://youtube''.''com (and optionally) http://youtube''.''com Does that work? Now, the site also uses Google cookies, but perhaps it's not practical to block those?

Modified by jscher2000

Was this helpful to you?
Quote
RobertJ
  • Top 10 Contributor
139 solutions 1428 answers

Also, the domain needs to be exact. For example: bing. com www.bing. com www2.bing. com

If you look at the site name in Manage Data, copy that exactly into the Manage Permissions. Usually, both of the protocols will be entered automatically.

See: Manage local site storage settings https://support.mozilla.org/en-US/kb/storage

Also, the domain needs to be exact. For example: bing. com '''www'''.bing. com '''www2'''.bing. com If you look at the site name in Manage Data, copy that ''exactly'' into the Manage Permissions. Usually, both of the protocols will be entered automatically. See: Manage local site storage settings https://support.mozilla.org/en-US/kb/storage
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17768 solutions 160699 answers

You should use the top level domain to include all sub level domains as it is always possible that there are links to other sub level domains or you can get different hosts due to server load balancing, so do not specify www.google.com, but use google.com with the proper protocol (https://google.com).

Did you verify that this is about cookies (there is a number in the cookies column) and not about storage ?

You should use the top level domain to include all sub level domains as it is always possible that there are links to other sub level domains or you can get different hosts due to server load balancing, so do not specify www.google.com, but use google.com with the proper protocol (https://google.com). Did you verify that this is about cookies (there is a number in the cookies column) and not about storage ?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.