X
Tap here to go to the mobile version of the site.

Support Forum

How can I turn off the redirect notice?

Posted

Ever since it's been available I have used Google IFL as my search engine, so that when I type anything in the address bar, it just automatically goes to the most logical page. Suddenly this week, when I hit Enter, instead of going to the page, I get a Redirect Notice showing me what page it's about to take me to. I thought it was some Google thing but it doesn't happen on Chrome and from searching it seems it's a Firefox thing.

As an example, to get here, I typed mozilla support forum and I got the redirect notice shown in the attached screenshot.

Searching tells me that the setting for this is in about:config under accessibility.blockautorefresh - just set it to false. Great. Except that's the default setting and it's already set for false. Restarting Firefox does not change things.

I am using version 60.9.0esr (64-bit) and while it may have automatically downloaded an update earlier this week, it needs to be restarted to install it, and I did not restart Firefox between this not happening and this happening.

I should note that it never happens when clicking a link on any website. I have seen it rarely in the past when clicking an image on Google search results, but not very often - usually I am just taken to the page where the image lives. (This is why I thought it was a Google thing.) It only happens when I type into the address bar. I have even tried opening a new, blank tab and typing and it still gives the same redirect notice. When I click the Return to the previous page link, nothing happens.

So how can I actually turn this off? It's very annoying.

Ever since it's been available I have used Google IFL as my search engine, so that when I type anything in the address bar, it just automatically goes to the most logical page. Suddenly this week, when I hit Enter, instead of going to the page, I get a Redirect Notice showing me what page it's about to take me to. I thought it was some Google thing but it doesn't happen on Chrome and from searching it seems it's a Firefox thing. As an example, to get here, I typed mozilla support forum and I got the redirect notice shown in the attached screenshot. Searching tells me that the setting for this is in about:config under accessibility.blockautorefresh - just set it to false. Great. Except that's the default setting and it's already set for false. Restarting Firefox does not change things. I am using version 60.9.0esr (64-bit) and while it may have automatically downloaded an update earlier this week, it needs to be restarted to install it, and I did not restart Firefox between this not happening and this happening. I should note that it never happens when clicking a link on any website. I have seen it rarely in the past when clicking an image on Google search results, but not very often - usually I am just taken to the page where the image lives. (This is why I thought it was a Google thing.) It only happens when I type into the address bar. I have even tried opening a new, blank tab and typing and it still gives the same redirect notice. When I click the Return to the previous page link, nothing happens. So how can I actually turn this off? It's very annoying.
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

404 Bookmarks Download Sound Honey LastPass NoScript Video DownloadHelper

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

jscher2000
  • Top 10 Contributor
8773 solutions 71719 answers

Firefox doesn't do that...

Could you share the details of your "I feel lucky" search plugin's search URL? The simplest way to find that is to search with the Network Monitor open.

To open the Network Monitor in the lower part of the tab, you can use either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

When you submit a new search through the address bar, Firefox should list the full URL of the request and show any redirects along the way. To share a URL from the Network Monitor, use

right-click > Copy > Copy URL

and paste into a reply. This will give us the relevant parameters so we can test on ours.

Firefox doesn't do that... Could you share the details of your "I feel lucky" search plugin's search URL? The simplest way to find that is to search with the Network Monitor open. To open the Network Monitor in the lower part of the tab, you can use either: * "3-bar" menu button > Web Developer > Network * (menu bar) Tools > Web Developer > Network * (Windows) Ctrl+Shift+e When you submit a new search through the address bar, Firefox should list the full URL of the request and show any redirects along the way. To share a URL from the Network Monitor, use right-click > Copy > Copy URL and paste into a reply. This will give us the relevant parameters so we can test on ours.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8773 solutions 71719 answers

Forgot to mention: you might need to check the box for "Persist Logs" toward the right side of the filter line to keep the previous URL after a redirect.

Forgot to mention: you might need to check the box for "Persist Logs" toward the right side of the filter line to keep the previous URL after a redirect.
Was this helpful to you?
Quote

Question owner

Step One: Click + to open new tab Step Two: Shift+Ctrl+e to open Network window Step Three: Check Persist Logs Step Four: Type in address bar: wiki tom hanks <enter> Step Five: Screenshot (attached) Step Six: Copy and paste URL: https://www.google.com/url?q=https://en.wikipedia.org/wiki/Tom_Hanks

I don't use an add-on/plugin for IFL. It's been so long, but it was a string I entered into something in about:config ... or some other "backdoor" settings, and can now select in the regular Options page under Search. Or maybe there was an extension that did it for me, that I long ago deleted because it wasn't necessary to keep once the string had been entered....

If you need anything else, please say so. I really need to get this resolved. Thanks!

Step One: Click + to open new tab Step Two: Shift+Ctrl+e to open Network window Step Three: Check Persist Logs Step Four: Type in address bar: wiki tom hanks <enter> Step Five: Screenshot (attached) Step Six: Copy and paste URL: https://www.google.com/url?q=https://en.wikipedia.org/wiki/Tom_Hanks I don't use an add-on/plugin for IFL. It's been so long, but it was a string I entered into something in about:config ... or some other "backdoor" settings, and can now select in the regular Options page under Search. Or maybe there was an extension that did it for me, that I long ago deleted because it wasn't necessary to keep once the string had been entered.... If you need anything else, please say so. I really need to get this resolved. Thanks!
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158573 answers

This looks like a warning that comes from the Google website (server)/ Try to clear the Google cookies.

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
This looks like a warning that comes from the Google website (server)/ Try to clear the Google cookies. Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" for websites that cause problems: *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Manage Data "Clear the Cache": *Options/Preferences -> Privacy & Security<br>Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8773 solutions 71719 answers

Hi saladgoat, it's puzzling that the initial search request URL is not listed in the Network Monitor.

What is the name of the search plugin -- an "OpenSearch" XML-format plugin, rather than a binary NPAPI plugin like Flash -- on the Options page?

If we can't get the search parameters from an actual search, there is a way to decompress the search.json.mozlz4 file and extract the strings from there. (It involves my page at https://www.jeffersonscher.com/ffu/searchjson.html and viewing the extracted JSON file in a Firefox tab.)

But before that, you could try viewing the search request URL in the Browser Console. You can open the separate Browser Console window using either:

  • "3-bar" menu button > Web Developer > Browser Console
  • (menu bar) Tools > Web Developer > Browser Console
  • (Windows) Ctrl+Shift+j

Click the trash can icon at the upper left to clear the window, and on the same row, make sure Requests is selected. Then switch back over to your main window and try another search.

Then switch back over to the console window. Did Firefox log the request URL this time? We're looking for a URL that most likely starts with:

https://www.google.com/search?

The right-click menu item here is "Copy Link Location".

Hi saladgoat, it's puzzling that the initial search request URL is not listed in the Network Monitor. What is the name of the search plugin -- an "OpenSearch" XML-format plugin, rather than a binary NPAPI plugin like Flash -- on the Options page? If we can't get the search parameters from an actual search, there is a way to decompress the search.json.mozlz4 file and extract the strings from there. (It involves my page at https://www.jeffersonscher.com/ffu/searchjson.html and viewing the extracted JSON file in a Firefox tab.) But before that, you could try viewing the search request URL in the Browser Console. You can open the separate Browser Console window using either: * "3-bar" menu button > Web Developer > Browser Console * (menu bar) Tools > Web Developer > Browser Console * (Windows) Ctrl+Shift+j Click the trash can icon at the upper left to clear the window, and on the same row, make sure Requests is selected. Then switch back over to your main window and try another search. Then switch back over to the console window. Did Firefox log the request URL this time? We're looking for a URL that most likely starts with: https://www.google''.''com/search? The right-click menu item here is "Copy Link Location".
Was this helpful to you?
Quote

Question owner

First off, I am continuing the process started by jscher2000 and have not done the things noted by cor-el, as they seem completely different. (I did clear the cache, but I feel like cookies have no bearing as I am performing the search from a blank tab.)

So, on to the next steps from jscher2000:

Sorry I don't know what you mean about a search plugin. I am attaching a screenshot of my Options>Search page and also my Extensions and Plugins.

So again I opened a new blank tab and started the Console Browser as suggested. Emptied the trash but I see no Requests option to turn on.

Added a screenshot of results from typing wiki tom hanks <enter>

From top to bottom, these are the Copy Link results:

https://google.com/search?btnI=&q=wiki+tom+hanks https://www.google.com/search?btnI=&q=wiki+tom+hanks https://www.google.com/url?q=https://en.wikipedia.org/wiki/Tom_Hanks https://d.joinhoney.com/v2/stores/partials/find?domain=google.com https://www.google.com/favicon.ico

The second-to-last one is from a plugin called Honey. I doubt the last one is at all helpful, but there it is for the sake of completion.

Is this helpful? Let me know if you need more info.

Thanks!

First off, I am continuing the process started by jscher2000 and have not done the things noted by cor-el, as they seem completely different. (I did clear the cache, but I feel like cookies have no bearing as I am performing the search from a blank tab.) So, on to the next steps from jscher2000: Sorry I don't know what you mean about a search plugin. I am attaching a screenshot of my Options>Search page and also my Extensions and Plugins. So again I opened a new blank tab and started the Console Browser as suggested. Emptied the trash but I see no Requests option to turn on. Added a screenshot of results from typing wiki tom hanks <enter> From top to bottom, these are the Copy Link results: https://google.com/search?btnI=&q=wiki+tom+hanks https://www.google.com/search?btnI=&q=wiki+tom+hanks https://www.google.com/url?q=https://en.wikipedia.org/wiki/Tom_Hanks https://d.joinhoney.com/v2/stores/partials/find?domain=google.com https://www.google.com/favicon.ico The second-to-last one is from a plugin called Honey. I doubt the last one is at all helpful, but there it is for the sake of completion. Is this helpful? Let me know if you need more info. Thanks!
Was this helpful to you?
Quote

Question owner

ADD:

I just clicked on each of the first three links above and they all take me to the same Redirect Notice page. Probably to be expected, but thought I'd say it anyway.

ADD: I just clicked on each of the first three links above and they all take me to the same Redirect Notice page. Probably to be expected, but thought I'd say it anyway.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8773 solutions 71719 answers

Helpful Reply

Hi saladgoat, if I use a URL containing btnl= then I get the redirect notice, too. In Firefox, Edge, and Chrome:

https://www.google.com/search?btnI=&q=wiki+tom+hanks

I think this is related to that parameter, which must be how your "Google IFL" search plugin (they are called search plugins) works.

But if I install the Google "Browse by Name" add-on, a search generates this URL --

https://www.google.com/search?sourceid=navclient&gfns=1&q=wiki+tom+hanks

-- which doesn't trigger a redirection page on the way to Wikipedia.

Does it work in Firefox 60: https://addons.mozilla.org/firefox/addon/google-browse-by-name-search/

If not, you can find one here as well: https://mycroftproject.com/google-search-plugins.html (use Find to jump to Browse by Name)

Hi saladgoat, if I use a URL containing <code>btnl=</code> then I get the redirect notice, too. In Firefox, Edge, and Chrome: https://www.google.com/search?btnI=&q=wiki+tom+hanks I think this is related to that parameter, which must be how your "Google IFL" search plugin (they are called search plugins) works. But if I install the Google "Browse by Name" add-on, a search generates this URL -- https://www.google.com/search?sourceid=navclient&gfns=1&q=wiki+tom+hanks -- which doesn't trigger a redirection page on the way to Wikipedia. Does it work in Firefox 60: https://addons.mozilla.org/firefox/addon/google-browse-by-name-search/ If not, you can find one here as well: https://mycroftproject.com/google-search-plugins.html (use Find to jump to Browse by Name)
Was this helpful to you? 1
Quote

Question owner

The Browse By Name add-on works! Thank you.

But I am still confused as to what happened. I have been using the same procedures for years and certainly this IFL search got installed around the time Firefox switched from add-ons to extensions. So how did that btnl get in there? Or was it always there and Firefox (or something) has just now started treating it differently?

The Browse By Name add-on works! Thank you. But I am still confused as to what happened. I have been using the same procedures for years and certainly this IFL search got installed around the time Firefox switched from add-ons to extensions. So how did that btnl get in there? Or was it always there and Firefox (or something) has just now started treating it differently?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8773 solutions 71719 answers

saladgoat said

I have been using the same procedures for years and certainly this IFL search got installed around the time Firefox switched from add-ons to extensions. So how did that btnl get in there? Or was it always there and Firefox (or something) has just now started treating it differently?

I assume Firefox was sending the identical parameter all along, but now Google is giving a different response. Without a time machine, it's difficult to confirm.

''saladgoat [[#answer-1257220|said]]'' <blockquote> I have been using the same procedures for years and certainly this IFL search got installed around the time Firefox switched from add-ons to extensions. So how did that btnl get in there? Or was it always there and Firefox (or something) has just now started treating it differently? </blockquote> I assume Firefox was sending the identical parameter all along, but now Google is giving a different response. Without a time machine, it's difficult to confirm.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.