X
Tap here to go to the mobile version of the site.

Support Forum

Google Sheets suddenly stopped working / froze in Firefox, fine in Chrome

Posted

Slow loading, yellow bar appears every 30 seconds asking if I want to stop the page. Can't use this and am heavily reliant on G suite. Suddenly started about 1 week ago. Sheets simply freeze with 'working' dialogue. Number of tabs open has no impact on problem. Sheets load fine in Chrome. I've not changed anything/drivers etc, including graphics drivers in this time frame. Firefox may have updated, I forget...

Slow loading, yellow bar appears every 30 seconds asking if I want to stop the page. Can't use this and am heavily reliant on G suite. Suddenly started about 1 week ago. Sheets simply freeze with 'working' dialogue. Number of tabs open has no impact on problem. Sheets load fine in Chrome. I've not changed anything/drivers etc, including graphics drivers in this time frame. Firefox may have updated, I forget...
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

Jeremy Sanders 12 solutions 142 answers

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #('''Firefox 57 and above''') Click the Library button [[Image:57 library icon]] and choose History.<br>(Click the menu button [[Image:New Fx Menu]] and choose History in older Firefox versions.) #In the History menu, choose "Clear Recent History...". #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the "Clear Now" button. Further information can be found in the [[Delete browsing, search and download history on Firefox]] article. Did this fix your problems? Please report back to us! Thank you.
Was this helpful to you?
Quote

Question owner

Sadly, no impact. I still face a 30-90 second wait for Google sheets to load (on a 77 Mbps down / 16 Mbps up fibre connection). Sheets in Chrome are still fine.

Sadly, no impact. I still face a 30-90 second wait for Google sheets to load (on a 77 Mbps down / 16 Mbps up fibre connection). Sheets in Chrome are still fine.
Was this helpful to you?
Quote
WestEnd
  • Top 25 Contributor
60 solutions 5379 answers

I would recommend at this time this is probably a Google IP control settings and it's probably best to use Chrome for anything Google related.

I would recommend at this time this is probably a Google IP control settings and it's probably best to use Chrome for anything Google related.
Was this helpful to you?
Quote
thebl4ckd0g 0 solutions 1 answers

I have this problem as well. Rather than push people off to another browser, is Mozilla going to try and address this issue, since the workarounds don't work to fix it? It has to either be something Google did - or something FireFox did with the most recent update. I'm on version 69.0 of FireFox, and only started seeing it the 1st week of September 2019 here...

I have this problem as well. Rather than push people off to another browser, is Mozilla going to try and address this issue, since the workarounds don't work to fix it? It has to either be something Google did - or something FireFox did with the most recent update. I'm on version 69.0 of FireFox, and only started seeing it the 1st week of September 2019 here...
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.