Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On overleaf the cursor has a weird offset. Can anyone help fixing this?

  • 8 replies
  • 1 has this problem
  • 2309 views
  • Last reply by m3k0c6

more options

Im using Firefox on my kubuntu machine and the cursor in the overleaf.com editor has a weird offset. On my laptop (same setup: Kubuntu) I don't have this problem.

See the attached picture. The cursor is far to the right but when I type, letters are added where the blue arrow is pointing.

Chosen solution

I haven't discovered the fonts tab yet. It shows that this part is using Liberation Sans Narrow.

EDIT: On my laptop firefox is using DejaVu Sans Mono

EDIT2: I copied the settings from my laptop and the overleaf editor is working properly now. Thanks for your help!

Read this answer in context 👍 0

All Replies (8)

more options

Forgot the picture

more options

It looks like Firefox is confused about that font, showing misspelling marks (squiggly underlines) positioned as though the letters were much wider. Is that supposed to be the "monospaced" font (all characters the same width)?

more options

Thanks for you answer. How would I check if the font is monospaced?

more options

Well, the blue letters are not monspaced, a monospaced font looks like a terminal display or Courier. Code display areas often use a monospaced font so that is why I suspect some strange font switcheroo issue there.

function nothing(){
  // do nothing
}

To see what font Firefox is using, you can try the Inspector. Here's how:

right-click the problem text > Inspect Element

Firefox should open a pane in the lower part of the tab that shows an HTML tree diagram highlighting the selected element. If it is a canvas, we may be at a dead end, but if it is another kind of element, you can change the panel on the right from Rules (or whatever is shown there) to Fonts. If the bar that shows Rules, Layout, etc. doesn't show Fonts, use the triangle at the right end to change the display.

To see what font(s) the page wants to use, click the Computed panel heading, and scroll down to font-family to see what is listed there.

more options
more options

Chosen Solution

I haven't discovered the fonts tab yet. It shows that this part is using Liberation Sans Narrow.

EDIT: On my laptop firefox is using DejaVu Sans Mono

EDIT2: I copied the settings from my laptop and the overleaf editor is working properly now. Thanks for your help!

Modified by agre

more options

The screenshot shows a very small font with a width of 1px.

more options

Hi there! I am having the same issue with overleaf on Arch as well. How exactly did you copy the settings from your laptop? I'd really appreciate the help, thank you!

Modified by m3k0c6