Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Several websites do not recognize my computer

  • 5 replies
  • 1 has this problem
  • Last reply by jscher2000

more options

Using firefox with win 10 Several websites do not recognize my computer and always require me to answer security questions prior to logging on. I did not have this issue prior to win 10

All Replies (5)

more options

Hi eiluj-notroh, are you running the Extended Support Release of Firefox 60, or are you running the current release with "resist fingerprinting" turned on (so your browser self-identifies as version 60)?

Usually after the extra authentication (security questions, code sent to your phone, etc.), the site will set a cookie showing that you (your current browser) passed the test. As long as Firefox keeps sending the site that cookies, you do not have to pass their test again.

How can this go wrong?

(1) If you are visiting the site in a private window

Cookies are not written to disk in private windows, so whether they are session cookies or have an expiration date after we're all gone, they will evaporate when the last private window is closed in your session.

The two ways a site could open in a private window are:

(A) Creating a private window in a regular session (for example, Command+Shift+p or right-click > Open Link in New Private Window)

(B) Setting Firefox to use automatic private browsing on the Preferences page --

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security, then scroll down to the History section. Either of these will invoke automatic private browsing:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

(2) If Firefox is set to store ONLY session cookies, and you have not made an exception for the site.

You can check for this on the Preferences page, Privacy & Security panel, Cookies section. Make sure you do NOT have a checkmark for "Delete cookies and site data when Firefox is closed". If you do, you need to create "Allow" exceptions for sites where you want Firefox to accept persistent cookies.

(3) If Firefox is set to Clear History When it Closes and that includes Cookies

Most people do not have this setting, but you can double-check here: On the Preferences page, Privacy & Security panel, History section: make sure you do NOT have a checkmark for "Clear history when Firefox closes". If you want to use that feature with some types of data, use the Settings button to the right of it to confirm that Cookies are not being cleared.

(4) If you use an add-on that modifies how cookies work

There are extensions to manage cookie lifetimes and removal, including some that expire cookies for inactive tabs. There also are extensions that isolate pages in a container, which creates a separate cookie jar for the pages in that container which are invisible to pages outside that container.

(5) If you logged out of the site

The cookie identifies you to the site, but if your session ended, the site isn't going to start a new one automatically. So if you logged out on the site -- highly recommended for sites that have sensitive data or accounts you can't afford to have taken over -- then the site might pre-fill your user name on the login page, but you will need to sign in again.

(6) If external utility or privacy software cleans browser cookies

If you use CCleaner, Advanced SystemCare or other third party programs that touch browser data, set them not to touch Firefox data.

(7) If your IP address is unstable

Some sites link your identification to your IP address and require a new login if that changes. To minimize the potential for changes, you can check your Firefox connection settings on the Preferences page.

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your system settings (for example, Windows/IE "LAN" setting). "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Does any of that help?

more options

never heard of Extended Support Release or Firefox 60, and firefox just recently updated - so just the regular version. Currently Version 60.7.0esr (32-bit)

I happens about every other time I login to verizon to pay the bill. Always from same desktop computer using firefox.

I never use private browser. Cookies are "Accept until they expire" and is set to Remember History.

Use the default settings on balance - no add ons or other stuff (ccleaner ????)

more options

The "esr" on your version number indicates you are using the Extended Support Release. But it's still supported, so no worries there.

I don't know how long Verizon's site is supposed to remember you (for example, 7 days, 30 days, 1 year, or something else). Firefox has a "Storage Inspector" tool you can open by pressing Shift+F9. It will show you the cookies set by the site currently displayed in that tab. Usually a column will indicate the expiration date for each cookie. (To add/change columns, right-click any of the current column headings to show a list.) If that expiration time is shorter than your usual interval between visits to the site, that could be the problem.

Modified by jscher2000

more options

F9 does not do anything on the verizon login page or after I logged in?

more options

Whoops, sorry, it's Shift+F9. I will edit my previous reply, too.