X
Tap here to go to the mobile version of the site.

Support Forum

do not close new tab when unused

Posted

Actually not a FF problem, but really an extension problem. (Though some of the sentiment expressed still applies.)

Firefox has this "new" "intelligence" which is nothing but annoying...it closes an unused new tab. I would like to switch off this and any other remote/built-in "intelligence" and have full manual control, especially how my tabs work, just like in the old firefox when TMP was still fully usable... Where in the settings can this nonsense behavior be switched off or is it at least in the about:config? All this arrogance of telling the user "how things should be" is most annoying. But reason cannot be expected to come back to the "mozilla foundation" (ever since you got funded you are void of reality) after the addon/extension apocalypse...ever. You should scrap it all, go back to FF21 (the fastest ever browser) and start from scratch, keeping the learned lessons firmly in mind. You will die if you do not get real. But back to the question... Where in the settings can this nonsense behavior be switched off or is it at least in the about:config? Thank you, still have hope for what was once the beloved browser.

Actually not a FF problem, but really an extension problem. (Though some of the sentiment expressed still applies.) Firefox has this "new" "intelligence" which is nothing but annoying...it closes an unused new tab. I would like to switch off this and any other remote/built-in "intelligence" and have full manual control, especially how my tabs work, just like in the old firefox when TMP was still fully usable... Where in the settings can this nonsense behavior be switched off or is it at least in the about:config? All this arrogance of telling the user "how things should be" is most annoying. But reason cannot be expected to come back to the "mozilla foundation" (ever since you got funded you are void of reality) after the addon/extension apocalypse...ever. You should scrap it all, go back to FF21 (the fastest ever browser) and start from scratch, keeping the learned lessons firmly in mind. You will die if you do not get real. But back to the question... Where in the settings can this nonsense behavior be switched off or is it at least in the about:config? Thank you, still have hope for what was once the beloved browser.

Modified by spdgnzls

Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Wesley Branton
  • Top 10 Contributor
582 solutions 4953 answers

I can't say that I've ever had Firefox automatically close a tab that it considers to be "unused". In fact, I can fairly confidently say that it's not a Firefox feature at all.

What I believe you may be referring to is Firefox's ability to unload tabs if it's running low on memory. This is designed to be a performance enhancement, since there's no point in keeping tabs that haven't been accessed in a while open and eating up your computer's resources. The feature is only supposed to trigger when your computer is low on memory, in which case you don't really have a lot to spare.

Fortunately, there appears to be a way to disable this feature. Simply do the following:

  1. Type about:config in your Firefox address bar to open the Configuration Editor.
  2. Bypass the warning (we'll be careful, I promise).
  3. Find the browser.tabs.unloadOnLowMemory preference.
  4. Double click it to change the value to false.
  5. Restart Firefox.

Hope this helps.

I can't say that I've ever had Firefox automatically close a tab that it considers to be "unused". In fact, I can fairly confidently say that it's not a Firefox feature at all. What I believe you may be referring to is Firefox's ability to [https://www.ghacks.net/2019/03/01/firefox-67-automatically-unload-unused-tabs-to-improve-memory/ unload tabs if it's running low on memory]. This is designed to be a performance enhancement, since there's no point in keeping tabs that haven't been accessed in a while open and eating up your computer's resources. The feature is only supposed to trigger when your computer is low on memory, in which case you don't really have a lot to spare. Fortunately, there appears to be a way to disable this feature. Simply do the following: #Type <code>about:config</code> in your Firefox address bar to open the [[Configuration Editor for Firefox|Configuration Editor]]. #Bypass the warning (we'll be careful, I promise). #Find the <code>browser.tabs.unloadOnLowMemory</code> preference. #Double click it to change the value to <code>false</code>. #Restart Firefox. Hope this helps.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157447 answers

Helpful Reply

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you? 1
Quote

Question owner

What happens is, that when I open a new tab, then go to another one with a page loaded, the new one closes automatically without having been used at all. Sometimes I just want to have a new tab in between others, or want to go back and get a link, but this is not possible anymore (as it was in the good old firefox). How can this be fixed?

What happens is, that when I open a new tab, then go to another one with a page loaded, the new one closes automatically without having been used at all. Sometimes I just want to have a new tab in between others, or want to go back and get a link, but this is not possible anymore (as it was in the good old firefox). How can this be fixed?
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
310 solutions 1728 answers

Helpful Reply

Does this happen in the Safe Mode?

Does this happen in the Safe Mode?
Was this helpful to you? 1
Quote

Question owner

TyDraniu said

Does this happen in the Safe Mode?

No, it does not.

''TyDraniu [[#answer-1225411|said]]'' <blockquote> Does this happen in the Safe Mode? </blockquote> No, it does not.
Was this helpful to you?
Quote

Question owner

Found it, hint to try without extensions was right.

Shame on me to assume it was FF problem, it is not, it is an extension which causes it, I should / could have known, as it says in the description of the extension. https://addons.mozilla.org/en-US/firefox/addon/dont-close-last-tab/ How could only the new tab auto close be disabled?

Found it, hint to try without extensions was right. Shame on me to assume it was FF problem, it is not, it is an extension which causes it, I should / could have known, as it says in the description of the extension. https://addons.mozilla.org/en-US/firefox/addon/dont-close-last-tab/ How could only the new tab auto close be disabled?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8642 solutions 70721 answers

I don't understand that description but since you have used the extension, it probably all makes sense to you. The author has an email link down the left side of the page, so you could try to get support information or request some options. If that doesn't lead anywhere, you could consider alternative extensions that do what you need with fewer side effects.

I don't understand that description but since you have used the extension, it probably all makes sense to you. The author has an email link down the left side of the page, so you could try to get support information or request some options. If that doesn't lead anywhere, you could consider alternative extensions that do what you need with fewer side effects.
Was this helpful to you?
Quote

Question owner

Zero response from the author so far... Have not found any extensions that would avoid duplicate tabs, but not close new ones, do you any suggestions? Also, how can one avoid pre-loading/pre-fetching, since it seems to download a lot in the background, even though the many tabs are not being used/displayed? (There was once an extension that avoided that well: bartab).

Zero response from the author so far... Have not found any extensions that would avoid duplicate tabs, but not close new ones, do you any suggestions? Also, how can one avoid pre-loading/pre-fetching, since it seems to download a lot in the background, even though the many tabs are not being used/displayed? (There was once an extension that avoided that well: bartab).
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8642 solutions 70721 answers

One option is to find another extension or rewrite this one. Another is to "hack" it after you load it, using the Debug feature. I'll describe that, but since it's several steps, it would only make sense if you tend to keep Firefox open for long stretches of time (e.g., at least the whole day).

The extension has an internal list of pages that it closes:

let newTabs = new Set(["about:blank", "about:home", "about:newtab", "about:privatebrowsing"]);

You can use extension debugging to clear out the list and then the extension won't close anything.

Developer Tools Setup

To use the extension debugging feature, you first need to enable some settings checkboxes. This is a one-time process.

(1) Open the Developer Tools panel, e.g., Ctrl+Shift+i

(2) Open the Settings panel -- use the ••• menu at the upper right of the Dev Tools panel and click Settings (attached screenshot #1)

(3) Scroll to the bottom right and enable the last two checkboxes (attached screenshot #2)

Debug the Extension

(1) Type or paste about:debugging in the address bar and press Enter to load a page listing all your currently enabled extensions

(2) Click the Debug link for Don't Close Last Tab (attached screenshot #3) to open a separate window

(3) In the debugging window, switch to the Console and type or paste the following and then press Enter to run it (attached screenshot #4):

newTabs = [];

You're done. You now should be able to open as many new tabs as you like (attached screenshot #5). However, this is only good for the duration of the current session, or until you disable/enable the extension again.

One option is to find another extension or rewrite this one. Another is to "hack" it after you load it, using the Debug feature. I'll describe that, but since it's several steps, it would only make sense if you tend to keep Firefox open for long stretches of time (e.g., at least the whole day). The extension has an internal list of pages that it closes: let newTabs = new Set(["about:blank", "about:home", "about:newtab", "about:privatebrowsing"]); You can use extension debugging to clear out the list and then the extension won't close anything. '''Developer Tools Setup''' To use the extension debugging feature, you first need to enable some settings checkboxes. This is a one-time process. (1) Open the Developer Tools panel, e.g., Ctrl+Shift+i (2) Open the Settings panel -- use the &bull;&bull;&bull; menu at the upper right of the Dev Tools panel and click Settings (attached screenshot #1) (3) Scroll to the bottom right and enable the last two checkboxes (attached screenshot #2) '''Debug the Extension''' (1) Type or paste '''about:debugging''' in the address bar and press Enter to load a page listing all your currently enabled extensions (2) Click the Debug link for Don't Close Last Tab (attached screenshot #3) to open a separate window (3) In the debugging window, switch to the Console and type or paste the following and then press Enter to run it (attached screenshot #4): newTabs = []; You're done. You now should be able to open as many new tabs as you like (attached screenshot #5). However, this is only good for the duration of the current session, or until you disable/enable the extension again.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.