X
Tap here to go to the mobile version of the site.

Support Forum

upgrade to Firefox 67 broke my profile

Posted

I have have a profile folder that I have carried with me between computers to sync all of my addon preferences (NoScript per-site permissions).

After upgrading to Firefox 67 that profile now seems to be forever inaccessible to me. Attempts to launch it in the about:profiles page result in a message box titles

'You've launched an older version of Firefox'

The only options thereon are 'Create New Profile' and 'Quit'. My question: how do I regain access to the profile I spent months building up?

I have have a profile folder that I have carried with me between computers to sync all of my addon preferences (NoScript per-site permissions). After upgrading to Firefox 67 that profile now seems to be forever inaccessible to me. Attempts to launch it in the about:profiles page result in a message box titles 'You've launched an older version of Firefox' The only options thereon are 'Create New Profile' and 'Quit'. My question: how do I regain access to the profile I spent months building up?

Chosen solution

Try to remove compatibility.ini in this profile. You may have to edit prefs.js as well. Note that it isn't recommended to copy a full profile as this can cause issues. Only copy the data files you really need.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

anastrophe 0 solutions 5 answers

Skip the 'about:profiles' part. follow the instructions in the second half here:

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

under "Start the Profile Manager when Firefox is closed". if you're like me, it'll list 'default' and 'default-release'. select 'default' and make sure it's set to use that profile without asking.

that'll take you back to your old profile.

An absolutely horrendously idiotic choice on the part of Mozilla in doing this. Absolutely needless. It's just about pushed me to finally delete firefox after being loyal since about day one, sixteen years ago.

Skip the 'about:profiles' part. follow the instructions in the second half here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles under "Start the Profile Manager when Firefox is closed". if you're like me, it'll list 'default' and 'default-release'. select 'default' and make sure it's set to use that profile without asking. that'll take you back to your old profile. An absolutely horrendously idiotic choice on the part of Mozilla in doing this. Absolutely needless. It's just about pushed me to finally delete firefox after being loyal since about day one, sixteen years ago.

Modified by anastrophe

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17344 solutions 156782 answers

Chosen Solution

Try to remove compatibility.ini in this profile. You may have to edit prefs.js as well. Note that it isn't recommended to copy a full profile as this can cause issues. Only copy the data files you really need.

Try to remove compatibility.ini in this profile. You may have to edit prefs.js as well. Note that it isn't recommended to copy a full profile as this can cause issues. Only copy the data files you really need. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
Was this helpful to you? 1
Quote

Question owner

anastrophe said

Skip the 'about:profiles' part. follow the instructions in the second half here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles under "Start the Profile Manager when Firefox is closed". if you're like me, it'll list 'default' and 'default-release'. select 'default' and make sure it's set to use that profile without asking. that'll take you back to your old profile.

It does not. I did precisely this (well, adapted to my Linux system: launched

./firefox/firefox -P

in my home directory), only to get the exact same warning window mentioned in the initial message ('You've launched an older version of Firefox').

''anastrophe [[#answer-1224115|said]]'' <blockquote> Skip the 'about:profiles' part. follow the instructions in the second half here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles under "Start the Profile Manager when Firefox is closed". if you're like me, it'll list 'default' and 'default-release'. select 'default' and make sure it's set to use that profile without asking. that'll take you back to your old profile. </blockquote> It does not. I did precisely this (well, adapted to my Linux system: launched ./firefox/firefox -P in my home directory), only to get the exact same warning window mentioned in the initial message ('You've launched an older version of Firefox').
Was this helpful to you?
Quote

Question owner

cor-el said

Try to remove compatibility.ini in this profile.

Thank you, but in which profile?

The old one I want to restore or the new one that took over my browser without my permission?

''cor-el [[#answer-1224125|said]]'' <blockquote> Try to remove compatibility.ini in this profile. </blockquote> Thank you, but in ''which'' profile? The old one I want to restore or the new one that took over my browser without my permission?
Was this helpful to you?
Quote
anastrophe 0 solutions 5 answers

grobber said

anastrophe said
Skip the 'about:profiles' part. follow the instructions in the second half here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles under "Start the Profile Manager when Firefox is closed". if you're like me, it'll list 'default' and 'default-release'. select 'default' and make sure it's set to use that profile without asking. that'll take you back to your old profile.

It does not. I did precisely this (well, adapted to my Linux system: launched

./firefox/firefox -P

in my home directory), only to get the exact same warning window mentioned in the initial message ('You've launched an older version of Firefox').

So, according to this: http://kb.mozillazine.org/Installation_directory Your new firefox installation may be installed as /usr/lib/firefox-<version> or /usr/lib64/firefox-<version>

Try running that with the '-P' flag - maybe?

and according to this: https://www.howtogeek.com/255587/how-to-find-your-firefox-profile-folder-on-windows-mac-and-linux/

Your profile should be under /home/<username>/.mozilla/firefox/xxxxxxxx.default

Might require running the new FF with the -P then drilling over to the profile dir. Not sure. I use linux constantly, every day, but not on the desktop, just servers - so my desktop skills are weak.

oh, addendum - be sure and make a copy of that profile folder first. A simple

cp -a /home/<username>/.mozilla/firefox/xxxxxxxx.default /home/<username>/.mozilla/firefox/xxxxxxxx.default.bak or .safe or whatever should do the trick.

''grobber [[#answer-1224133|said]]'' <blockquote> ''anastrophe [[#answer-1224115|said]]'' <blockquote> Skip the 'about:profiles' part. follow the instructions in the second half here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles under "Start the Profile Manager when Firefox is closed". if you're like me, it'll list 'default' and 'default-release'. select 'default' and make sure it's set to use that profile without asking. that'll take you back to your old profile. </blockquote> It does not. I did precisely this (well, adapted to my Linux system: launched ./firefox/firefox -P in my home directory), only to get the exact same warning window mentioned in the initial message ('You've launched an older version of Firefox'). </blockquote> So, according to this: http://kb.mozillazine.org/Installation_directory Your new firefox installation may be installed as /usr/lib/firefox-<version> or /usr/lib64/firefox-<version> Try running that with the '-P' flag - maybe? and according to this: https://www.howtogeek.com/255587/how-to-find-your-firefox-profile-folder-on-windows-mac-and-linux/ Your profile should be under /home/<username>/.mozilla/firefox/xxxxxxxx.default Might require running the new FF with the -P then drilling over to the profile dir. Not sure. I use linux constantly, every day, but not on the desktop, just servers - so my desktop skills are weak. oh, addendum - be sure and make a copy of that profile folder first. A simple cp -a /home/<username>/.mozilla/firefox/xxxxxxxx.default /home/<username>/.mozilla/firefox/xxxxxxxx.default.bak or .safe or whatever should do the trick.

Modified by anastrophe

Was this helpful to you?
Quote

Question owner

anastrophe said

So, according to this: http://kb.mozillazine.org/Installation_directory Your new firefox installation may be installed as /usr/lib/firefox-<version> or /usr/lib64/firefox-<version> Try running that with the '-P' flag - maybe?

Well, it's directly <HOME>/firefox for me because I installed the program directly, not through my Linux distro's package manager.

And that's precisely what I did: ran that executable (<HOME>/firefox/firefox) with the -P flag, thus opening the profile manager.

and according to this: https://www.howtogeek.com/255587/how-to-find-your-firefox-profile-folder-on-windows-mac-and-linux/ Your profile should be under /home/<username>/.mozilla/firefox/xxxxxxxx.default Might require running the new FF with the -P then drilling over to the profile dir. Not sure. I use linux constantly, every day, but not on the desktop, just servers - so my desktop skills are weak. oh, addendum - be sure and make a copy of that profile folder first. A simple cp -a /home/<username>/.mozilla/firefox/xxxxxxxx.default /home/<username>/.mozilla/firefox/xxxxxxxx.default.bak or .safe or whatever should do the trick.

I know where the profile folder is: exactly as you describe, in the <HOME>/.mozilla/firefox folder. That's where I've been keeping my preferred profile, syncing it between computers with rsync (drawing from a copy of it I keep in cloud storage, which all of my computers have access to).

If I simply copy its contents on top of whatever other profiles I have I get the same warning window and the two options I'm not interested in ('create new profile' and 'quit').

The same thing happens if I set my preferred profile as 'default' or try to open it in a new window, etc. There's simply no apparent way to get Mozilla to accept running it.

''anastrophe [[#answer-1224144|said]]'' <blockquote> So, according to this: http://kb.mozillazine.org/Installation_directory Your new firefox installation may be installed as /usr/lib/firefox-<version> or /usr/lib64/firefox-<version> Try running that with the '-P' flag - maybe? </blockquote> Well, it's directly <HOME>/firefox for me because I installed the program directly, not through my Linux distro's package manager. And that's precisely what I did: ran that executable (<HOME>/firefox/firefox) with the -P flag, thus opening the profile manager. <blockquote> and according to this: https://www.howtogeek.com/255587/how-to-find-your-firefox-profile-folder-on-windows-mac-and-linux/ Your profile should be under /home/<username>/.mozilla/firefox/xxxxxxxx.default Might require running the new FF with the -P then drilling over to the profile dir. Not sure. I use linux constantly, every day, but not on the desktop, just servers - so my desktop skills are weak. oh, addendum - be sure and make a copy of that profile folder first. A simple cp -a /home/<username>/.mozilla/firefox/xxxxxxxx.default /home/<username>/.mozilla/firefox/xxxxxxxx.default.bak or .safe or whatever should do the trick. </blockquote> I know where the profile folder is: exactly as you describe, in the <HOME>/.mozilla/firefox folder. That's where I've been keeping my preferred profile, syncing it between computers with rsync (drawing from a copy of it I keep in cloud storage, which all of my computers have access to). If I simply copy its contents on top of whatever other profiles I have I get the same warning window and the two options I'm not interested in ('create new profile' and 'quit'). The same thing happens if I set my preferred profile as 'default' or try to open it in a new window, etc. There's simply no apparent way to get Mozilla to accept running it.
Was this helpful to you?
Quote

Question owner

cor-el said

Try to remove compatibility.ini in this profile.

Just reporting back that this worked. There was no need to fiddle with prefs.js in any way. Simply removing compatibility.ini from the old profile I wanted back and setting that profile as default in about:profiles resulted in it restarting without the nagging window.

Thank you!

''cor-el [[#answer-1224125|said]]'' <blockquote> Try to remove compatibility.ini in this profile. </blockquote> Just reporting back that this worked. There was no need to fiddle with prefs.js in any way. Simply removing compatibility.ini from the old profile I wanted back and setting that profile as default in about:profiles resulted in it restarting without the nagging window. Thank you!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.