Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New version of firefox is not compatible for most websites

more options

Hi, Firefox post v62, is not compatible for many websites, and do not load as intended. Few examples:

https://tnpds.gov.in/pages/registeracard/register-a-card.xhtml (this website used to work well in Firefox v62, but not now. From the attached image you can see a pop-up, which does not show now in firefox v64.

Likewise https://ssup.uidai.gov.in/ssup/login.html, after login (for aadhaar address update) the language translation does not work at all.

And: many sites which depend something like "load unsigned scripts" as displayed in Chrome, does not load in Firefox at all, since the same if enabled in Chrome the website works as intended.

Kindly look into this. I have tried all options in Firefox, but it doesn't seems to help any way.

Thanks.

MAHENDRA.

Attached screenshots

All Replies (1)

more options

It's hard to diagnose the problem, as I can't log in for obvious reasons. Most likely this is a problem with the website, I'd check what the browser console says (F12). Most likely some script is loaded either through (unsecure) http or from another domain, which could be blocked by Firefox's privacy settings.