X
Tap here to go to the mobile version of the site.

Support Forum

Edges of Firefox Browser is way, way off sometimes. Has been for months.

Posted

Edges of FF Browser is way, way off. I have several screenshots of this. The only way to correct the issue is to minimize and maximize, + or - the Browser until it snaps out of it. I'm going to restart my system in a minute here, to reset everything. Issue has gotten slightly worse this past week or so.

I use Firefox quantum 66.0.1 64bit on Linux Mint 64 bit on 24" screen PC with newer hardware. I use Chromium occasionally and I have not seen this border issue there. FF Browser seems to only do this when I use it on a Linux system, haven't seen this issue yet on windows. I have wondered if this issue is related to me using very large displays. I use a 24" screen.

This particular problem doesn't bother me much, but I thought I might say something.

Thanks!

Edges of FF Browser is way, way off. I have several screenshots of this. The only way to correct the issue is to minimize and maximize, + or - the Browser until it snaps out of it. I'm going to restart my system in a minute here, to reset everything. Issue has gotten slightly worse this past week or so. I use Firefox quantum 66.0.1 64bit on Linux Mint 64 bit on 24" screen PC with newer hardware. I use Chromium occasionally and I have not seen this border issue there. FF Browser seems to only do this when I use it on a Linux system, haven't seen this issue yet on windows. I have wondered if this issue is related to me using very large displays. I use a 24" screen. This particular problem doesn't bother me much, but I thought I might say something. Thanks!
Attached screenshots

Chosen solution

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

FredMcD
  • Top 10 Contributor
4221 solutions 58917 answers

Chosen Solution

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt xulstore.json file.

Close Firefox. Open your file browser to this hidden location:

  • Mac: *~/Library/Application Support/Firefox/Profiles
  • Linux: *~/.mozilla/firefox/Profiles
  • Windows: %AppData%\Mozilla\Firefox\Profiles
  • *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles
  • Windows XP: C:\Documents and Settings\<user>\Application Data
    \Mozilla\Firefox\Profiles\

Search for the above files. Then rename or delete them. Restart Firefox.

https://support.mozilla.org/en-US/kb/changes-toolbars-and-window-sizes-are-not-saved You may have corrupt '''xulstore.json''' file. '''Close Firefox. ''' Open your file browser to this hidden location: * '''Mac: ''' *~/Library/Application Support/Firefox/Profiles * '''Linux: ''' *~/.mozilla/firefox/Profiles * '''Windows: ''' %AppData%\Mozilla\Firefox\Profiles * *C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles * '''Windows XP: ''' C:\Documents and Settings\<user>\Application Data<br> \Mozilla\Firefox\Profiles\ Search for the above files. Then rename or delete them. Restart Firefox.
Was this helpful to you?
Quote

Question owner

OK. I went in to each of my profile folders and made the changes as you described. I deleted each xulstore.json file. then I started the browser. It seems to have done the trick! Thank you.

OK. I went in to each of my profile folders and made the changes as you described. I deleted each xulstore.json file. then I started the browser. It seems to have done the trick! Thank you.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4221 solutions 58917 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.