X
Tap here to go to the mobile version of the site.

Support Forum

How to disable firefox asking if I really want to launch .msi file?

Posted

Every time I download *.msi file and try to launch it through firefox last downloads menu (or library window) firefox warns me that this is executable file and asks do I really want to launch this. This is really annoying.

How to disable this warning?

P.S. I do not want to use about:preferences#privacy to disable warning me about insecure downloads! I want to only remove this stupid warning before launching legitimate .msi files just because they are .msi files. I still want firefox to scan all downloads.

Every time I download *.msi file and try to launch it through firefox last downloads menu (or library window) firefox warns me that this is executable file and asks do I really want to launch this. This is really annoying. How to disable this warning? P.S. I do not want to use about:preferences#privacy to disable warning me about insecure downloads! I want to only remove this stupid warning before launching legitimate .msi files just because they are .msi files. I still want firefox to scan all downloads.

Modified by Piterk

Chosen solution

OK, I've found it in the source code.

Add the following pref: browser.download.skipConfirmLaunchExecutable = true


Code line Bug 1472635 Btw, it's there since Fx63 :).

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

TyDraniu
  • Top 25 Contributor
284 solutions 1592 answers

Go to about:config and set browser.download.manager.alertOnEXEOpen = false.

Go to ''about:config'' and set ''browser.download.manager.alertOnEXEOpen'' = '''false'''.
Was this helpful to you?
Quote

Question owner

Unfortunately it did not help. I had it on disabled earlier. I have no warning on exe files, only on msi files. This is something new, silently added in firefox 65.

Unfortunately it did not help. I had it on disabled earlier. I have no warning on exe files, only on msi files. This is something new, silently added in firefox 65.
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
284 solutions 1592 answers

Chosen Solution

OK, I've found it in the source code.

Add the following pref: browser.download.skipConfirmLaunchExecutable = true


Code line Bug 1472635 Btw, it's there since Fx63 :).

OK, I've found it in the source code. Add the following pref: ''browser.download.skipConfirmLaunchExecutable'' = '''true''' <hr> [https://searchfox.org/mozilla-central/source/toolkit/components/downloads/DownloadUIHelper.jsm#116 Code line] [https://bugzilla.mozilla.org/show_bug.cgi?id=1472635 Bug 1472635] Btw, it's there since Fx63 :).

Modified by TyDraniu

Was this helpful to you? 1
Quote

Question owner

I created string and set it to true and it did not work. Now I cannot create boolean because it only changes what string says.

I created string and set it to true and it did not work. Now I cannot create boolean because it only changes what string says.
Was this helpful to you?
Quote
TyDraniu
  • Top 25 Contributor
284 solutions 1592 answers

...

  1. Right-click on the pref and select Resetuj.
  2. Restart the browser.
  3. Try again to create a boolean preference.
... # Right-click on the pref and select '''Resetuj'''. # Restart the browser. # Try again to create a boolean preference.
Was this helpful to you?
Quote

Question owner

Thanks! That solved the problem, string disappeared after resetting it. Now I created boolean and message is not popping up on msi files!

Thanks! That solved the problem, string disappeared after resetting it. Now I created boolean and message is not popping up on msi files!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.