Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do eliminate the redirect from DuckDuckGo through r.serch.yahoo.com, which never loads my favorite pages?

  • 25 replies
  • 1 has this problem
  • 48 views
  • Last reply by JCosmoAsp

more options

Some of my favorite web pages are now unavailable because search requests are redirected to the "r.search.yahoo.com" server, which results in a no-load timeout error. Just started last week. I have found no solutions online, other that someone selling a malware program that claims to find and remove it. I have refreshed Firefox, to no avail. I have searched this forum, without result. I may be missing something here (the forum), but wonder if this is a result of malware that neither Malwarebytes or Norton Security is missing. Any ideas out there?

All Replies (5)

more options

JCosmoAsp said

Nope, same result in Safe Mode.

Thanks for testing that. Could you check your connection settings here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. You may want to try "No proxy".

Any difference?

more options

jscher2000 said

JCosmoAsp said
Nope, same result in Safe Mode.

Thanks for testing that. Could you check your connection settings here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. You may want to try "No proxy".

Any difference?

Sorry, Jefferson, no difference. Btw, I thank you for all your thoughtful consideration. I doubt I could afford your hourly rates! I ditched DDG for Bing, but no difference. Neither Safari nor Firefox will load it. Is that a clue? Could there be a site security issue with rockler.com?

more options

The best place to determine things and for help is to go to the Pros :

more options

JCosmoAsp said

I doubt I could afford your hourly rates!

Probably only justifiable as a business expense.

I ditched DDG for Bing, but no difference. Neither Safari nor Firefox will load it. Is that a clue? Could there be a site security issue with rockler.com?

If multiple browsers are affected, it does sound like something upstream. If it's not some software running on your Mac, how about your router / cable modem / DSL modem? If you haven't already, you could "power cycle" that box (either turn it off/on or unplug, wait 10 seconds, plug back in).

more options

jscher2000 said

JCosmoAsp said
I doubt I could afford your hourly rates!

Probably only justifiable as a business expense.

I ditched DDG for Bing, but no difference. Neither Safari nor Firefox will load it. Is that a clue? Could there be a site security issue with rockler.com?

If multiple browsers are affected, it does sound like something upstream. If it's not some software running on your Mac, how about your router / cable modem / DSL modem? If you haven't already, you could "power cycle" that box (either turn it off/on or unplug, wait 10 seconds, plug back in).

Rebooted the Hughesnet modem (Gen5); no difference. I'm going to try the Malwarebytes Forum, too. Maybe somebody there has some advice.

  1. 1
  2. 2