X
Tap here to go to the mobile version of the site.

Support Forum

while accessing site css and script return 400 bad request

Posted

We are facing one issue in our application. The UI design of this application is breaking when we accessed it via Mozilla firefox browser.

It is working fine in other browsers. We have done a research on this issue and below are the findings we got.

1. When checked the response content using developer tools it was found that the response header has “server” value “Microsoft-HTTPAPI/2.0” instead of “Microsoft-IIS/8.5”. All the javascript/css/images file requests to server are returning with 400 bad request.

2. On further research we have done on this behavior we found that it is something related to HTTP.SYS API component in IIS. We got some related information on this issue from one of the official Microsoft documentation given in below link.

https://docs.microsoft.com/en-us/iis/troubleshoot/diagnosing-http-errors/troubleshooting-http-400-errors-in-iis

Above said things are the case when we accessed this application in desktop. This application is actually intended to use in mobile devices as well. So below are the behavior of application when accessed in Mozilla browser in Mobile devices.

1. In Apple IPad, it is working fine when taken in Mozilla firefox.

2. In Android device (Mobile/IPad) it is exhibiting same issue explained above when taken in Mozilla firefox browser.

We are facing one issue in our application. The UI design of this application is breaking when we accessed it via Mozilla firefox browser. It is working fine in other browsers. We have done a research on this issue and below are the findings we got. 1. When checked the response content using developer tools it was found that the response header has “server” value “Microsoft-HTTPAPI/2.0” instead of “Microsoft-IIS/8.5”. All the javascript/css/images file requests to server are returning with 400 bad request. 2. On further research we have done on this behavior we found that it is something related to HTTP.SYS API component in IIS. We got some related information on this issue from one of the official Microsoft documentation given in below link. https://docs.microsoft.com/en-us/iis/troubleshoot/diagnosing-http-errors/troubleshooting-http-400-errors-in-iis Above said things are the case when we accessed this application in desktop. This application is actually intended to use in mobile devices as well. So below are the behavior of application when accessed in Mozilla browser in Mobile devices. 1. In Apple IPad, it is working fine when taken in Mozilla firefox. 2. In Android device (Mobile/IPad) it is exhibiting same issue explained above when taken in Mozilla firefox browser.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 20.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
4272 solutions 59922 answers

Separate Security Issue: Update your Flash Player Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 28.0.0.161

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Separate Security Issue: Update your Flash Player '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 28.0.0.161 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
FredMcD
  • Top 10 Contributor
4272 solutions 59922 answers

Please provide public link(s) (no password) that we can check out. No Personal Information Please !

Please provide public link(s) (no password) that we can check out. '''No Personal Information Please ! '''
cor-el
  • Top 10 Contributor
  • Moderator
17585 solutions 159080 answers

This issue can be caused by corrupted Cookies or Cookies that are blocked.

Clear the cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache:

  • Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now"

"Remove the Cookies" from websites that cause problems.

  • Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> cookies: "Show cookies"
This issue can be caused by corrupted Cookies or Cookies that are blocked. *check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions" *https://support.mozilla.org/en-US/kb/fix-login-issues-on-websites-require-passwords Clear the cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache: *Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now" "Remove the Cookies" from websites that cause problems. *Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> cookies: "Show cookies"