X
Tap here to go to the mobile version of the site.

Support Forum

Why am I limited to few File extensions for opening files from windows?

Posted

Today, I attempted to open a .gif file with Firefox web browser version 57.0.2 (64 bit) using windows 7 and I found that when I opened firefox as a program through the 'open with' prompt, it would not comply by setting firefox as the default program, instead it left the 'open with' prompt open as if I hadn't selected anything. Instead of right clicking the .gif file I tried to set the .gif files to open with firefox via the control panel, Folder options, Change the file type associated with a file extension option. This led me to the same prompt as right clicking and I had no success. I tried 'set default programs' in control panel and found that a very short list of file extensions can be selected as turned on or off for default use with firefox. When I go to menu options in the Firefox browser, the .gif file extension, among many others, does not have an option for default settings. I can open the .gif files from the firefox web browser, but I am curious as to why I can no longer open them from my computer folders directly. There seems to have been a change in that feature of firefox web browser.

Today, I attempted to open a .gif file with Firefox web browser version 57.0.2 (64 bit) using windows 7 and I found that when I opened firefox as a program through the 'open with' prompt, it would not comply by setting firefox as the default program, instead it left the 'open with' prompt open as if I hadn't selected anything. Instead of right clicking the .gif file I tried to set the .gif files to open with firefox via the control panel, Folder options, Change the file type associated with a file extension option. This led me to the same prompt as right clicking and I had no success. I tried 'set default programs' in control panel and found that a very short list of file extensions can be selected as turned on or off for default use with firefox. When I go to menu options in the Firefox browser, the .gif file extension, among many others, does not have an option for default settings. I can open the .gif files from the firefox web browser, but I am curious as to why I can no longer open them from my computer folders directly. There seems to have been a change in that feature of firefox web browser.

Chosen solution

Dragging should probably work nevertheless as well as choosing File > Open File… - I think this is a known Windows issue.

- Apart from uninstalling the Mozilla Maintenance service (that should not be necessary as that should go happen with uninstalling/installing Firefox), did you actually uninstall Firefox itself properly too, i.e. using Add or Remove Programs in the Control panel?

- Are you sure there are no Firefox installs listed there, and (perhaps more important) no remaining Mozilla Firefox folders in both C:\Program Files and C:\Program Files (x86) when using a file explorer?

- Recently Mozilla has moved 32-bit Firefox users to 64-bit in 56.0.1, so this could have happened automatically. The point is, also looking at this question/thread at Microsoft (expand all replies and also click "this post" written on Dec 20 2012), the exact issue can occur if the actual program cannot be found, so that could be fixed by (quote) "moving the program from the folder "Program Files (x86)" to "Program Files"" (better: make sure to install to the proper folder only rather than moving files), or by fixing the registry entry manually.

In other words, if for some reason Windows still looks at C:\Program Files (x86)\Mozilla Firefox for the former 32-bit install) instead of C:\Program Files\Mozilla Firefox that should now contain the 64-bit version, it will not allow you to register it for handling .gif files. You can imagine if there is a firefox.exe in an older 32-bit folder that may not have been removed - but is still known to Windows and selected each time by you - the issue could persist.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16391 solutions 147875 answers

Try to rename/remove handlers.json and delete mimeTypes.rdf if present in the Firefox profile folder with Firefox closed to reset all file actions.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try to rename/remove handlers.json and delete mimeTypes.rdf if present in the Firefox profile folder with Firefox closed to reset all file actions. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

cor-el said

Try to rename/remove handlers.json and delete mimeTypes.rdf if present in the Firefox profile folder with Firefox closed to reset all file actions. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Unfortunately, this did not seem to solve the problem. I still can't set .gif files on my computer to open with firefox unless I open them from firefox. I just finished trying this action, I will update if this changes.

''cor-el [[#answer-1055664|said]]'' <blockquote> Try to rename/remove handlers.json and delete mimeTypes.rdf if present in the Firefox profile folder with Firefox closed to reset all file actions. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox </blockquote> Unfortunately, this did not seem to solve the problem. I still can't set .gif files on my computer to open with firefox unless I open them from firefox. I just finished trying this action, I will update if this changes.
Tonnes
  • Top 25 Contributor
  • Locale Leader
245 solutions 1453 answers

I don’t think any Firefox version registers the .gif file type for itself during install, where (perhaps) it used to do so years ago if I remember well. Also, the list you referred to describes settings for MIME types, not file extensions (see this page for more).

If you want to set Firefox as your default program to open gif files, you need Windows to instruct it as such, and make sure other programs do not (i.e. unregister them) if needed. The way you tried this should work in Windows, and you should also be offered a "Always use the selected program..." prompt from that. Do make sure to point to the firefox.exe program, not one already offered in the list by Windows. It probably does not recognize Firefox as an image viewer, hence it may not appear there.

You may however wonder whether or not it’s good to set Firefox as a default program for this purpose - some people prefer to keep the original program and just drag e.g. a .gif or .png file to Firefox when needed / occasionally.

I don’t think any Firefox version registers the .gif file type for itself during install, where (perhaps) it used to do so years ago if I remember well. Also, the list you referred to describes settings for ''MIME types'', not file extensions (see [[Change what Firefox does when you click on or download a file|this page]] for more). If you want to set Firefox as your default program to open gif files, you need Windows to instruct it as such, and make sure other programs do not (i.e. unregister them) if needed. The way you tried this should work in Windows, and you should also be offered a "Always use the selected program..." prompt from that. Do make sure to point to the firefox.exe program, not one already offered in the list by Windows. It probably does not recognize Firefox as an image viewer, hence it may not appear there. You may however wonder whether or not it’s good to set Firefox as a default program for this purpose - some people prefer to keep the original program and just drag e.g. a .gif or .png file to Firefox when needed / occasionally.

Question owner

Tonnes said

I don’t think any Firefox version registers the .gif file type for itself during install, where (perhaps) it used to do so years ago if I remember well. Also, the list you referred to describes settings for MIME types, not file extensions (see this page for more). If you want to set Firefox as your default program to open gif files, you need Windows to instruct it as such, and make sure other programs do not (i.e. unregister them) if needed. The way you tried this should work in Windows, and you should also be offered a "Always use the selected program..." prompt from that. Do make sure to point to the firefox.exe program, not one already offered in the list by Windows. It probably does not recognize Firefox as an image viewer, hence it may not appear there. You may however wonder whether or not it’s good to set Firefox as a default program for this purpose - some people prefer to keep the original program and just drag e.g. a .gif or .png file to Firefox when needed / occasionally.

I did point to firefox.exe. When I select the .exe the window closes and I'm left with the (open with..). Window as if I had not selected browse or navigated to a program. There is no prompt or error message. What I would normally expect is that the windows would close or give me the option to always use this program or something like that and when I open .gif files they open with Firefox web browser. This is not happening and I have no clue why.

''Tonnes [[#answer-1055708|said]]'' <blockquote> I don’t think any Firefox version registers the .gif file type for itself during install, where (perhaps) it used to do so years ago if I remember well. Also, the list you referred to describes settings for ''MIME types'', not file extensions (see [[Change what Firefox does when you click on or download a file|this page]] for more). If you want to set Firefox as your default program to open gif files, you need Windows to instruct it as such, and make sure other programs do not (i.e. unregister them) if needed. The way you tried this should work in Windows, and you should also be offered a "Always use the selected program..." prompt from that. Do make sure to point to the firefox.exe program, not one already offered in the list by Windows. It probably does not recognize Firefox as an image viewer, hence it may not appear there. You may however wonder whether or not it’s good to set Firefox as a default program for this purpose - some people prefer to keep the original program and just drag e.g. a .gif or .png file to Firefox when needed / occasionally. </blockquote> I did point to firefox.exe. When I select the .exe the window closes and I'm left with the (open with..). Window as if I had not selected browse or navigated to a program. There is no prompt or error message. What I would normally expect is that the windows would close or give me the option to always use this program or something like that and when I open .gif files they open with Firefox web browser. This is not happening and I have no clue why.

Modified by jamesofthejungle

Tonnes
  • Top 25 Contributor
  • Locale Leader
245 solutions 1453 answers

Interesting. Did you recently switch Firefox from the 32-bit to 64-bit version perhaps?

If so, uninstall Firefox from Add/Remove Programs (you won’t lose personal settings), make sure there is no 32-bit version installed too (uninstall if so), and reinstall the 64-bit version from here.

I found this suggestion here - the thread may be useful for other suggestions and info.

Interesting. Did you recently switch Firefox from the 32-bit to 64-bit version perhaps? If so, uninstall Firefox from Add/Remove Programs (you won’t lose personal settings), make sure there is no 32-bit version installed too (uninstall if so), and reinstall the 64-bit version from [https://www.mozilla.org/firefox/all/ here]. I found this suggestion [https://superuser.com/questions/655600/i-cant-set-a-program-as-the-default-to-open-a-filetype-with-in-windows-7 here] - the thread may be useful for other suggestions and info.

Question owner

Tonnes said

Interesting. Did you recently switch Firefox from the 32-bit to 64-bit version perhaps? If so, uninstall Firefox from Add/Remove Programs (you won’t lose personal settings), make sure there is no 32-bit version installed too (uninstall if so), and reinstall the 64-bit version from here. I found this suggestion here - the thread may be useful for other suggestions and info.

I did not recently upgrade that I know of, I don't know if Mozilla maintenance service may have done. I had tried uninstalling and re-installing, but I have tried it again. I uninstalled Chrome, disconnected form my wifi network, Ran TFC cleaner by old timer, and uninstalled Firefox and Mozilla maintenance service from control panel. I also deleted the Maintenance service folders. I downloaded and reinstalled with the link you provided using internet explorer and I still get the same results. If anyone has recreated this problem, let me know.

''Tonnes [[#answer-1055847|said]]'' <blockquote> Interesting. Did you recently switch Firefox from the 32-bit to 64-bit version perhaps? If so, uninstall Firefox from Add/Remove Programs (you won’t lose personal settings), make sure there is no 32-bit version installed too (uninstall if so), and reinstall the 64-bit version from [https://www.mozilla.org/firefox/all/ here]. I found this suggestion [https://superuser.com/questions/655600/i-cant-set-a-program-as-the-default-to-open-a-filetype-with-in-windows-7 here] - the thread may be useful for other suggestions and info. </blockquote> I did not recently upgrade that I know of, I don't know if Mozilla maintenance service may have done. I had tried uninstalling and re-installing, but I have tried it again. I uninstalled Chrome, disconnected form my wifi network, Ran TFC cleaner by old timer, and uninstalled Firefox and Mozilla maintenance service from control panel. I also deleted the Maintenance service folders. I downloaded and reinstalled with the link you provided using internet explorer and I still get the same results. If anyone has recreated this problem, let me know.

Modified by jamesofthejungle

Pkshadow
  • Top 10 Contributor
917 solutions 11966 answers

What happens when you drag a gif into the screen from a folder or desktop ? An animated one. It should play or see. I can always see it. This is how your going to have to use it if it works for you like that.

What happens when you drag a gif into the screen from a folder or desktop ? An animated one. It should play or see. I can always see it. This is how your going to have to use it if it works for you like that.
Tonnes
  • Top 25 Contributor
  • Locale Leader
245 solutions 1453 answers

Chosen Solution

Dragging should probably work nevertheless as well as choosing File > Open File… - I think this is a known Windows issue.

- Apart from uninstalling the Mozilla Maintenance service (that should not be necessary as that should go happen with uninstalling/installing Firefox), did you actually uninstall Firefox itself properly too, i.e. using Add or Remove Programs in the Control panel?

- Are you sure there are no Firefox installs listed there, and (perhaps more important) no remaining Mozilla Firefox folders in both C:\Program Files and C:\Program Files (x86) when using a file explorer?

- Recently Mozilla has moved 32-bit Firefox users to 64-bit in 56.0.1, so this could have happened automatically. The point is, also looking at this question/thread at Microsoft (expand all replies and also click "this post" written on Dec 20 2012), the exact issue can occur if the actual program cannot be found, so that could be fixed by (quote) "moving the program from the folder "Program Files (x86)" to "Program Files"" (better: make sure to install to the proper folder only rather than moving files), or by fixing the registry entry manually.

In other words, if for some reason Windows still looks at C:\Program Files (x86)\Mozilla Firefox for the former 32-bit install) instead of C:\Program Files\Mozilla Firefox that should now contain the 64-bit version, it will not allow you to register it for handling .gif files. You can imagine if there is a firefox.exe in an older 32-bit folder that may not have been removed - but is still known to Windows and selected each time by you - the issue could persist.

Dragging should probably work nevertheless as well as choosing File > Open File… - I think this is a known Windows issue. - Apart from uninstalling the Mozilla Maintenance service (that should not be necessary as that should go happen with uninstalling/installing Firefox), did you actually uninstall Firefox itself properly too, i.e. using Add or Remove Programs in the Control panel? - Are you sure there are no Firefox installs listed there, and (perhaps more important) no remaining ''Mozilla Firefox'' folders in both ''C:\Program Files'' and ''C:\Program Files (x86)'' when using a file explorer? - Recently Mozilla has moved 32-bit Firefox users to 64-bit in 56.0.1, so this could have happened automatically. The point is, also looking at [https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/cant-choose-program-as-a-default-program/8535870a-d133-459a-a80c-bd6581298fee this question/thread] at Microsoft (expand all replies and also click "this post" written on Dec 20 2012), the exact issue can occur if the actual program cannot be found, so that could be fixed by (quote) "moving the program from the folder "Program Files (x86)" to "Program Files"" (better: make sure to install to the proper folder only rather than moving files), or by fixing the registry entry manually. In other words, if for some reason Windows still looks at C:\Program Files (x86)\Mozilla Firefox for the former 32-bit install) instead of C:\Program Files\Mozilla Firefox that should now contain the 64-bit version, it will not allow you to register it for handling .gif files. You can imagine if there is a firefox.exe in an older 32-bit folder that may not have been removed - but is still known to Windows and selected each time by you - the issue could persist.

Question owner

Tonnes said

Dragging should probably work nevertheless as well as choosing File > Open File… - I think this is a known Windows issue. - Apart from uninstalling the Mozilla Maintenance service (that should not be necessary as that should go happen with uninstalling/installing Firefox), did you actually uninstall Firefox itself properly too, i.e. using Add or Remove Programs in the Control panel? - Are you sure there are no Firefox installs listed there, and (perhaps more important) no remaining Mozilla Firefox folders in both C:\Program Files and C:\Program Files (x86) when using a file explorer? - Recently Mozilla has moved 32-bit Firefox users to 64-bit in 56.0.1, so this could have happened automatically. The point is, also looking at this question/thread at Microsoft (expand all replies and also click "this post" written on Dec 20 2012), the exact issue can occur if the actual program cannot be found, so that could be fixed by (quote) "moving the program from the folder "Program Files (x86)" to "Program Files"" (better: make sure to install to the proper folder only rather than moving files), or by fixing the registry entry manually. In other words, if for some reason Windows still looks at C:\Program Files (x86)\Mozilla Firefox for the former 32-bit install) instead of C:\Program Files\Mozilla Firefox that should now contain the 64-bit version, it will not allow you to register it for handling .gif files. You can imagine if there is a firefox.exe in an older 32-bit folder that may not have been removed - but is still known to Windows and selected each time by you - the issue could persist.

I feel a little silly because I think you are right. I installed 32 bit and it works fine. I suspect I can now install 64 bit and make sure it is being installed in the proper place. I did not have any folders left from uninstalls besides the mozilla maintenance service. I seem to remember that mozilla maintenance service was a separate uninstallable program. I can't remember, but I removed it.

Thanks

''Tonnes [[#answer-1056207|said]]'' <blockquote> Dragging should probably work nevertheless as well as choosing File > Open File… - I think this is a known Windows issue. - Apart from uninstalling the Mozilla Maintenance service (that should not be necessary as that should go happen with uninstalling/installing Firefox), did you actually uninstall Firefox itself properly too, i.e. using Add or Remove Programs in the Control panel? - Are you sure there are no Firefox installs listed there, and (perhaps more important) no remaining ''Mozilla Firefox'' folders in both ''C:\Program Files'' and ''C:\Program Files (x86)'' when using a file explorer? - Recently Mozilla has moved 32-bit Firefox users to 64-bit in 56.0.1, so this could have happened automatically. The point is, also looking at [https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/cant-choose-program-as-a-default-program/8535870a-d133-459a-a80c-bd6581298fee this question/thread] at Microsoft (expand all replies and also click "this post" written on Dec 20 2012), the exact issue can occur if the actual program cannot be found, so that could be fixed by (quote) "moving the program from the folder "Program Files (x86)" to "Program Files"" (better: make sure to install to the proper folder only rather than moving files), or by fixing the registry entry manually. In other words, if for some reason Windows still looks at C:\Program Files (x86)\Mozilla Firefox for the former 32-bit install) instead of C:\Program Files\Mozilla Firefox that should now contain the 64-bit version, it will not allow you to register it for handling .gif files. You can imagine if there is a firefox.exe in an older 32-bit folder that may not have been removed - but is still known to Windows and selected each time by you - the issue could persist. </blockquote> I feel a little silly because I think you are right. I installed 32 bit and it works fine. I suspect I can now install 64 bit and make sure it is being installed in the proper place. I did not have any folders left from uninstalls besides the mozilla maintenance service. I seem to remember that mozilla maintenance service was a separate uninstallable program. I can't remember, but I removed it. Thanks