Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Open new tab from email in the same window

  • 15 replies
  • 2 have this problem
  • 32 views
  • Last reply by Svetlana

more options

Helo there, Could you please help me wth this new tab Anytime I open from my email this (see below in attachment) I will get a new window open with this ,but what I need is that this will open in the one I already have open and just add as a new tab.I remember that this wasn't doing before ,but that was long time ago and I just decide to write you know if there maybe a way how to fix it

All Replies (15)

more options

If you want to disable any links from opening new windows and instead open in tabs. Do:

  1. Go to about:config
  2. Set browser.link.open_newwindow.restriction to 0.
more options

Hi, I did what yu told me and still not working

more options

Can you provide the name of the website. Also your screenshot was not attached in the first post.

more options

You can override how external links are opened via the browser.link.open_newwindow.override.external pref. If this pref has the default value -1 then browser.link.open_newwindow is used. The meaning of the value of browser.link.open_newwindow.override.external is the same as of browser.link.open_newwindow

more options

Hello, I still have the same problem , When I try to open a any link or file like html from email it will open in new tab not next to multi tab that I already have opened please help me with this because this is annoying

more options

Hi ikrtek, just in case cor-el's suggestion was not clear:

Sometimes a link has a script attached, and that can override the normal "divert to tab" behavior. To force scripts to launch new windows in a new tab, you may need to modify a setting. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

  • 3 = divert new window to a new tab (default) <= This should already be set; if it's not, right-click > Reset to restore the default
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

  • 0 = apply the setting under (A) to ALL new windows (even script windows) <= Try this one
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default) <= this should already be set; if it's not, right-click > Reset to restore the default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

To return to normal if things go haywire, right-click each "modified" preference and choose Reset.

Does it help with your email links?

more options

Does it help to set browser.link.open_newwindow.restriction to 0?

More information: http://kb.mozillazine.org/Browser.link.open_newwindow.restriction

more options

Hello,thank you for respond , basically that is what I did from the start when jagan try to help me with that. I did all what I supposed to do but still doing the same ;-( See image I took screen shot from the setting I did

more options

Hi ikrtek, what is this picture from?

They look a bit like attachments. Attachments might behave differently from regular links if they are forced downloads.

more options

The are html attachment form the email,but any link that I try to open from the email will open in new window instead of line up as new Tab on the same window where I already have Tab's open

more options

I would like more information.

1. Please test the behaviour of the link at this page: http://www.webdevout.net/test?02r&raw

2. When you see a link that does not behave correctly, select it, right-click, click 'View Selection Source' and copy-paste that into your answer or attach it as a file.

more options

Please also confirm that the following are set

  • browser.link.open_newwindow.override.external = -1,
  • browser.link.open_newwindow.restriction = 0
  • browser.link.open_newwindow = 3
more options

When you send the as TESTlink it opened as it supposed to ,wow so why these firefox.html files are not opening the same way?

more options

Hello ikrtek,

Thanks for checking. Please also follow step 2 in my previous reply to provide more information to help with diagnosing the problem.

more options

Hello,

When you see a link that does not behave correctly, select it, right-click, click 'View Selection Source' and copy-paste that into your answer or attach it as a file.

We need this information to know what the problem is.

Please check and write back.