X
Tap here to go to the mobile version of the site.

Support Forum

Can't install any add-ons - "You need to download Firefox to install this add-on.". Firefox is latest version.

Posted

After upgrading to Quantum, I'm unable to install any add-ons from https://addons.mozilla.org.

I've made sure I'm using the latest version of Firefox.

When I find an add-on I want to install (having checked it's compatible with Quantum), the 'Add To Firefox' button is always disabled and below is a red banner saying: "You need to download Firefox to install this add-on."

Does anyone have any suggestions?

Edit - I've also made sure there are no active add-ons.

Thanks

After upgrading to Quantum, I'm unable to install any add-ons from https://addons.mozilla.org. I've made sure I'm using the latest version of Firefox. When I find an add-on I want to install (having checked it's compatible with Quantum), the 'Add To Firefox' button is always disabled and below is a red banner saying: "You need to download Firefox to install this add-on." Does anyone have any suggestions? Edit - I've also made sure there are no active add-ons. Thanks

Modified by Bluegreen0

Chosen solution

Quote

Additional System Details

Installed Plug-ins

OpenH264 Video Codec provided by Cisco Systems, Inc.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36

More Information

philipp
  • Top 10 Contributor
  • Moderator
4880 solutions 21604 answers

Chosen Solution

hello, please see if this helps: How to reset the default user agent on Firefox

hello, please see if this helps: [[How to reset the default user agent on Firefox]]
Was this helpful to you? 4
Quote

Question owner

Thanks philipp, that worked. Appreciate your help (and the quick response).

As an aside, even when the button was disabled, I found I was able to download the add-on xpi manually.

Right-click the disabled "Add To Firefox" button, and select "Save Link As". Then drag and drop the downloaded xpi file on to Firefox to install it.

Thanks philipp, that worked. Appreciate your help (and the quick response). As an aside, even when the button was disabled, I found I was able to download the add-on xpi manually. Right-click the disabled "Add To Firefox" button, and select "Save Link As". Then drag and drop the downloaded xpi file on to Firefox to install it.
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.