X
Tap here to go to the mobile version of the site.

Support Forum

.htaccess redirect from www to non-www not working in Firefox?

Posted

.htaccess redirect

RewriteCond %{HTTP_HOST} ^www\.ice\-warrior\.com$ RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$ RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$ RewriteRule ^/?$ "https\:\/\/ice\-warrior\.com\/" [R=301,L]

Not working in Firefox - works on all other browsers. SHould redirect https://www.ice-warrior.com to https://ice-warrior.com

.htaccess redirect RewriteCond %{HTTP_HOST} ^www\.ice\-warrior\.com$ RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$ RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$ RewriteRule ^/?$ "https\:\/\/ice\-warrior\.com\/" [R=301,L] Not working in Firefox - works on all other browsers. SHould redirect https://www.ice-warrior.com to https://ice-warrior.com

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.79 Safari/537.36

More Information

Shadow110 1072 solutions 14836 answers

You could try empty your cache and delete cookies for site/s That has worked in the past. Not sure how google likes it but you can place in the <head> a <meta http-equiv=</> to redirect to the page or a 302 Redirect Have you checked with the server support team and also looked at the .htaccess file to see if corrupted ?

Is this something new you are setting up or is this a existing site that worked before any Firefox updates ?

You could try empty your cache and delete cookies for site/s That has worked in the past. Not sure how google likes it but you can place in the <head> a <meta http-equiv=&lt;/> to redirect to the page or a 302 Redirect Have you checked with the server support team and also looked at the .htaccess file to see if corrupted ? Is this something new you are setting up or is this a existing site that worked before any Firefox updates ?

Modified by Shadow110

jscher2000
  • Top 10 Contributor
8793 solutions 71930 answers

I get:

Your connection is not secure

[Advanced panel]

www.ice-warrior.com uses an invalid security certificate. The certificate is only valid for the following names: earth-warrior.com, ice-warrior.com Error code: SSL_ERROR_BAD_CERT_DOMAIN

So in that case, because there's no connection, Firefox does not get the redirect. Neither does Internet Explorer 11. (I'm curious why Chrome doesn't have this issue; they may have some special workaround for this situation?)

It's a little odd because Comodo usually gives you both the base domain and the www subdomain. Not sure if they'll "fix it for free" or whether you need some kind of Plan B to resolve this.

I get: Your connection is not secure [Advanced panel] www.ice-warrior.com uses an invalid security certificate. The certificate is only valid for the following names: earth-warrior.com, ice-warrior.com Error code: SSL_ERROR_BAD_CERT_DOMAIN So in that case, because there's no connection, Firefox does not get the redirect. Neither does Internet Explorer 11. (I'm curious why Chrome doesn't have this issue; they may have some special workaround for this situation?) It's a little odd because Comodo usually gives you both the base domain and the www subdomain. Not sure if they'll "fix it for free" or whether you need some kind of Plan B to resolve this.