X
Tap here to go to the mobile version of the site.

Support Forum

Firefox forces itself to be default browser

Posted

When I run Firefox, it makes itself default browser automatically. In the General Options, the check box for "Always check if Firefox is your default browser" is marked and readonly, grayed out, so I can not unmark it. I am on Windows 7, Firefox version: 52.3.0 (32-bit) I tried uninstalling and removing all the related folders then install again. Problem continues.

Looking at Control Panel\Programs\Default Programs\Set Default Programs Before I run Firefox, it says This program has 0 out of 9 defaults. After I run Firefox it says "This program has all its defaults".

When I run Firefox, it makes itself default browser automatically. In the General Options, the check box for "Always check if Firefox is your default browser" is marked and readonly, grayed out, so I can not unmark it. I am on Windows 7, Firefox version: 52.3.0 (32-bit) I tried uninstalling and removing all the related folders then install again. Problem continues. Looking at Control Panel\Programs\Default Programs\Set Default Programs Before I run Firefox, it says This program has 0 out of 9 defaults. After I run Firefox it says "This program has all its defaults".

Chosen solution

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36

More Information

Josh Ross 12 solutions 143 answers

Have you tried completely uninstalling Firefox, setting your default browser of your choice and installing the newest version of Firefox? That might help you out with the issues.

Have you tried completely uninstalling Firefox, setting your default browser of your choice and installing the newest version of Firefox? That might help you out with the issues.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
3172 solutions 42864 answers

Chosen Solution

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.