On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't login to gmail on Firefox v54.0 64-bit

  • 3 replies
  • 26 have this problem
  • 6 views
  • Last reply by cor-el

more options

A few weeks ago Google seems to have changed their login page to web-based gmail. On it, there is now a big blue "Next" button. It is inactive on my Firefox for Linux, v 54,0, 64-bit.

I don't know if it's Firefox or Gmail. It is working on v54.0, 64-bit on Windows for me.

I have been using Firefox with Gmail for years without issues.

I have shut off all my extensions, restarted, cleared all history and cookies, all to no avail.

For now my only recourse is to use Chrome :-( . Unfortunately I don't have a lot of time to debug this... as long as Chrome works, I can get my email and well that's what I need. But I thought I'd report it anyhow.

Thanks.

A few weeks ago Google seems to have changed their login page to web-based gmail. On it, there is now a big blue "Next" button. It is inactive on my Firefox for Linux, v 54,0, 64-bit. I don't know if it's Firefox or Gmail. It is working on v54.0, 64-bit on Windows for me. I have been using Firefox with Gmail for years without issues. I have shut off all my extensions, restarted, cleared all history and cookies, all to no avail. For now my only recourse is to use Chrome :-( . Unfortunately I don't have a lot of time to debug this... as long as Chrome works, I can get my email and well that's what I need. But I thought I'd report it anyhow. Thanks.

Chosen solution

Thanks. I tried safe mode- that worked. When I restarted again, however, it failed.

So then I shut off hardware acceleration, restarted. No joy.

So then I refreshed Firefox, and made sure hardware acceleration is back on. It works.

I'll reinstall my extensions- I had just a few- and note if/when Firefox fails to work with Gmail.

Thanks!

Read this answer in context 👍 1

All Replies (3)

more options

Try this : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode It may work, has worked in the past for Gmail issues. Are you running the latest Firefox release ? is 54.0.1 for Windows, no idea for Linux.

In info sent I see that there might be some issues with your video card/drivers. https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration Try No Acceleration on Gmail see if that helps.

Please let us know if this solved your issue or if need further assistance.

more options

Chosen Solution

Thanks. I tried safe mode- that worked. When I restarted again, however, it failed.

So then I shut off hardware acceleration, restarted. No joy.

So then I refreshed Firefox, and made sure hardware acceleration is back on. It works.

I'll reinstall my extensions- I had just a few- and note if/when Firefox fails to work with Gmail.

Thanks!

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure that your extensions and filters are updated to the latest version

This issue can be caused by corrupted cookies or cookies that are blocked.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window